Questions tagged [tls]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
52 views

Common Name for CA-Signed CSR in MTLS?

I am trying to set up MTLS for my client->server SOAP Apex callout to an external web app, following the directions in these help articles: https://developer.salesforce.com/docs/atlas.en-us....
DCastel's user avatar
0 votes
0 answers
179 views

Apex callouts - TLS ciphersuite

I'm working on an integration with Salesforce using Apex code to make outgoing API calls. One of our users is asking what cipher is being used. Is there any way to figure this out? Some way of viewing ...
James's user avatar
  • 337
1 vote
0 answers
812 views

MTLS certificate error

I have been breaking my head to get the Mutual Authentication(MTLS) to work in Salesforce for a while but with little success. I am trying this out on a sandbox by enabling this feature and by ...
Anee's user avatar
  • 381
0 votes
0 answers
351 views

How to Upgrade TLS to the last version on Marketing Cloud?

I came from this thread TLS Upgrade on Marketing Cloud where I can see information about the impact of the deprecation of TLS 1.0 but I can't see concise instructions to upgrade TLS on demand. How ...
Mrquestion's user avatar
0 votes
0 answers
58 views

Disable TLS requirement for Salesforce Out Bound Messages

Is there a way in Salesforce to disable this required authentication for outbound messages? We are getting Error of Server chose TLSv1. Now the server we have is Running Frame Work of 4.7 which ...
Ahmad's user avatar
  • 101
0 votes
0 answers
86 views

SalesForce OutBound message Server chose TLSv1, but that protocol version is not enabled or not supported

I have a listener on a ASMX webservice here is the following code: using System; using System.Collections.Generic; using System.Linq; using System.Net; using System.Web; using System.Web....
Francis's user avatar
0 votes
0 answers
31 views

How to check what TLS protocol FuelSDK-PHP is using? [duplicate]

I think the FuelSDK-PHP is using TLSv1, so the question is how to check it.. and how to get it to v1.2, if thats even possible? This is for PHP not for JAVA, as the other thread is.
Bidstrup's user avatar
  • 483
0 votes
1 answer
358 views

How to check which TLS protocol is using the FUEL-SDK for java

Salesforce Marketing cloud recently announced the retirement of the TLS 1.0 based connections effective early August this year, and they published a Knowledge Article with useful information and some ...
Leo's user avatar
  • 111
0 votes
2 answers
211 views

Python SalesForce FuelSDK TLS - which version

Recently SalesForce Marketing Cloud announced retirement of the TLS 1.0 based connections effective early August this year. I am using Python SalesForce FuelSDK to manage my API connections and ...
user55964's user avatar
0 votes
1 answer
42 views

My Ant scripts stopped to work in the last few days. Could it be related to TLS 1.0 disablement?

My scripts have been working for years. I made no changes. Token and pass are fine. Last known successful run was about 15 days ago - around 2018-04-10. Today I got Failed to login: Failed to send ...
Uwe Heim's user avatar
  • 28.3k
2 votes
1 answer
528 views

How to find out who is still sending TLS 1.0 mails to Salesforce

We are getting mails from Salesforce (the company) warning that incoming or outgoing mails to/from Salesforce (the system) are still using TLS 1.0. The warning is not more explicit, it says incoming ...
Sander de Jong's user avatar
0 votes
2 answers
125 views

Getting redirected intermediate URL https://mydomain.secure.force.com/secur/weakhttps.jsp?l=1

I have implemented a gateway for my site. We send request to gateway and gateway send response msg. but recently we are not getting response and when checked in logs of gateway we found an error An ...
Dnyaneshwar's user avatar
-1 votes
1 answer
62 views

Getting Unsuported Client TLS 1.1 error

We have integration between .net web application and Salesforce. In Salesforce from Certificate Object we select list of records and we click on the "Generate Certificate Button" the Button is Java ...
Samuel Robert's user avatar
2 votes
0 answers
2k views

invalid grant when requesting API token from Salesforce

I'm having a terrible time...I am trying to get coldfusion to get a token from salesforce, but I am stuck on the following error {"error":"invalid_grant","error_description":"authentication failure"}...
Jay Rizzi's user avatar
  • 465
2 votes
3 answers
2k views

How to find whether my callout is using TLS 1.0 or 1.1?

We have just upgraded our SAP server to support TLS 1.1. Now, I need to find out using which protocol version my callouts are going to SAP. I have checked debug log but did not any such information. ...
Bforce's user avatar
  • 6,828
0 votes
1 answer
73 views

TLS 1.0 Disablement/ Inbound API integrations

We are preparing for the TLS1.0 disablement, and part of the checklist is to test any inbound API integrations. I’m not aware of what inbound API integrations we’re using, if any. Is there any way ...
sfdc's user avatar
  • 13.6k
0 votes
1 answer
344 views

Salesforce Sandbox API, using .Net web service - Please use TLS 1.1 or higher [duplicate]

I'm getting this error when trying to connect to the Salesforce sandbox API via a .NET SOAP webservice, when using IIS 10. None of the other similar questions I've found on Salesforce Stack Exchange ...
Chris Halcrow's user avatar
1 vote
1 answer
362 views

Action required on TLS 1.0 disablement - where do I use it in marketing cloud?

I need hints on where to look when it comes to salesforce disabling TLS 1.0. I recieved an email from salesforce about action required but it wasn't specified on where I use it and since im not ...
Axel Ekeberg's user avatar
4 votes
1 answer
544 views

Disabling TLS 1.0 in sandbox? [duplicate]

Critical Update option shows Disabling older TLS Option in Production Org but not in Sandbox Org?What could be the reason? Does it mean Sandbox has already disabled TLS 1.0 it as mentioned here?
Priyalakshmi's user avatar
  • 1,456
0 votes
3 answers
2k views

Error: Something went wrong. Please try again.Remote host closed connection during handshake

I am making an HTTP POST request to external system, it works fine when I post request from Developer orgs, these orgs are of older versions. However when I build a package and install that package ...
Nachiket Deshpande's user avatar
0 votes
2 answers
549 views

The impending TLS upgrade

I have been working on a project in which I utilised the following php library in order to push data to Salesforce using the REST API. https://github.com/gmo/salesforce-rest-api Everything was ...
cosmicsafari's user avatar
1 vote
2 answers
525 views

Effect of TLS update in Apex Data Loader?

Does TLS update have any impact in apex Data loader? If it so, in what way will it affect? What measures has to be taken in order to use Data loader after that update?
Priyalakshmi's user avatar
  • 1,456
1 vote
1 answer
590 views

CA-signed Certificate: What URL (Common Name)

I'm trying to set up mutual authentication with a third-party. I want to create a new CA signed certificate but I don't know what URL I should use. Testing from our sandbox.
Dildar Hussain's user avatar
8 votes
1 answer
282 views

Salesforce email says I'm connecting via TLS 1.0 but that protocol does not appear in login history

I received an email recently that reads: Your org has been identified as having users or integrations still connecting to Salesforce using TLS 1.0 encryption protocol during the month of ...
Swisher Sweet's user avatar
7 votes
1 answer
9k views

How to be sure API calls are using TLS 1.2

We are using .Net to make web service calls the Salesforce API. Is there a way to know for sure that the calls are using TLS 1.2? Are there any API logs or records of the protocol is use in Salesforce ...
Swisher Sweet's user avatar
2 votes
1 answer
1k views

TLS 1.2 Using Partner wsdl

I have been using the Partner wsdl to connect to SalesForce from my C# application for a few years. When I found out that SalesForce was turning off TLS 1.0, I did some reading and found out that ...
Brian Worthington's user avatar
2 votes
0 answers
788 views

TLS Version not changing from TLSv1.0 to TLSv1.2 [closed]

I am trying to enable TLSv1.2 using SSLContext and i tried System.setProperty("https.protocols", "TLSv1.2"). I am want to enable it for salesforce soap API in my application. The issue is when i run ...
Fazeen Ahmad's user avatar
1 vote
1 answer
815 views

Remote Site Supports TLSv1.1 and Higher but Still throwing callout exception [closed]

Salesforce disabled TLSv1.0 for sandboxes on June 25, 2016. Problem : Receiving TLS support error suddenly eventhough remote site and browser supports TLSv1.1 and higher versions. Before June 2016, ...
mohammed azarudeen's user avatar
0 votes
1 answer
1k views

Cannot Connect to https://tls1test.salesforce.com/services/Soap/u/34.0

UPDATE/FOUND ISSUE: After checking and checking I found it had to do with our OpenSLL module being 0.9.x (....oh man) which does not support TLSv1 and why my test failed but SSL Labs passed. So I have ...
Ray's user avatar
  • 103
4 votes
1 answer
185 views

Workaround for TLS

We are using a number of integration operations with different systems and some of those systems are not going to be updated to the TLS 1.1 cryptographic protocols or higher anytime soon. This systems ...
Carlos Naranjo's user avatar
4 votes
1 answer
134 views

Salesforce SOQL and database/record inline edit standalone Application for PC

I'm a longtime Mac user who fell in love with the SOQLExplorer's capability to run a query, double click a field on a returned record, modify the value, and thus update the record in Salesforce. ...
rmarq423's user avatar
  • 967
0 votes
1 answer
203 views

TLS 1.0 - issues if I disable it?

I am integrating a .NET web application with Salesforce via the Partner WSDL and SOAP API. I am currently getting an error UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. ...
andrewb's user avatar
  • 203
0 votes
1 answer
378 views

How do I get my test SalesForce instance to work with our Java hosting environment?

We are trying to get our J2EE hosting environment (Jboss 7.1.3.AS) working with our test SalesForce instance. We are running Java 6 v 111 java version "1.6.0_111" Java(TM) SE Runtime Environment (...
Dave's user avatar
  • 87
7 votes
2 answers
401 views

How do I discover who's still connecting to Salesforce using TLS 1.0?

I recently got the standard warning email from SF saying that the prod instances will turn off TLS 1.0 next year, and they've detected some of our connections are still using it. Is there any way I ...
Bradley Thomas's user avatar
2 votes
2 answers
2k views

TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https

Error message: <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:sf="urn:fault.enterprise.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">...
TESt ADG10's user avatar
2 votes
2 answers
15k views

Use TLS 1.1 or higher

I am using Force.com IDE-Eclipse Mars and jre7. I have added -Dhttps.protocols=TLSv1.1,TLSv1.2 in Eclipse.ini ,but still I am getting this error.I am trying to fetch data from Sandbox. What am I ...
newbiesalesforce's user avatar
1 vote
1 answer
258 views

Can Force.com Sites enforce https without a certificate from it’s branded custom domain?

I have a situation where the CNAME record on a domain will be updated to look up to a force.com site. Currently the “Enforce HTTPS” checkbox on our force.com sites config is checked and we would like ...
Renny-Rem's user avatar
0 votes
2 answers
763 views

Stronger Security is Required popup on Internet Explorer

I always get the popup message below when I login to our sandbox. I already configured my browser for Salesforce and followed the instructions on the articles below, but, I can't get rid of it. ...
Sam's user avatar
  • 93
2 votes
2 answers
1k views

TLS version and HTTP supported in production

We have not activated the update 'TLS1.1 for HTTPS' in our production org. So which version of TLS are right now supported by it? I mean does it support only TLS1.0 or it would support TLS 1.1? And ...
Saumya Ranjan Satapathy's user avatar
2 votes
1 answer
21k views

Server chose TLSv1, but that protocol version is not enabled or not supported by the client

Environment : Sandbox I am using callout to pull the data from api to Salsesforce. It was working untill salesforce disable TLS 1.0. Today I ran the apex callout and got the following error System....
mohammed azarudeen's user avatar
3 votes
3 answers
4k views

Not able to connect to sandbox org through Force.com IDE and Data Loader - TLS protocol issue

I am not able to connect to sandbox org through Force.com IDE and Data Loader. It is giving error "TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to ...
Rohit Patil's user avatar
4 votes
1 answer
1k views

Sandbox org TLS 1.1 update breaks outbound calls

This morning, our team arrived to find our sandbox instance in disarray. Salesforce had disabled TLS 1.0 across the entire instance, breaking our homegrown applications that communicate with it via ...
Jesse Smith's user avatar
1 vote
1 answer
6k views

How to enable TLS 1.1 or Tls1.2 in Java 7

I am using salesforce soap API i has activated tls 1.1 in SF-->Critical updates i am getting this error UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or ...
Fazeen Ahmad's user avatar
6 votes
1 answer
1k views

Server to Server JWT Authentication Certificate management

I'm writing an application to sync some data from a service to salesforce and back. I'm working with a developer account and so far I was able to implement the bulk of the needed functionality merely ...
LoG's user avatar
  • 161
6 votes
2 answers
5k views

Callouts to web services started failing with CalloutException: Server chose TLSv1

Today I started receiving the following exception when making callouts to external web services: System.CalloutException: IO Exception: Server chose TLSv1, but that protocol version is not enabled ...
Daniel Ballinger's user avatar
3 votes
1 answer
2k views

Salesforce disabled TLS 1.0 encryption

Could you please help me with this issue? Actually SF uses TLS 1.0 encryption for the communication between the external app and the platform. But regarding to the last communication of SF this ...
David Lirio's user avatar
8 votes
1 answer
519 views

What would be the proactive steps that we need to take when salesforce disables SSL and enables TLS?

I heard that salesforce would stop the support for SSL 3.0 and will enforce TLS 1.0 and higher. https://help.salesforce.com/apex/HTViewSolution?urlname=Salesforce-disabling-SSL-3-0-encryption From ...
Bforce's user avatar
  • 6,828
6 votes
1 answer
10k views

Ensuring my application complies with SSL3.0 being disabled?

I have developed an application in C# that makes use of the Salesforce API via a WSDL and need to ensure that the upcoming disabling of SSL3.0 will not affect functionality. I have never had to do any ...
Jdinklage Morgoone's user avatar