0

I always get the popup message below when I login to our sandbox.

enter image description here

I already configured my browser for Salesforce and followed the instructions on the articles below, but, I can't get rid of it.

Salesforce disabling TLS 1.0

Configuring Internet Explorer

This is only happening in sandbox.

Is there anything else that I should configure for this to work?

4
  • This is a bit tongue-in-cheek, but have you considered using a browser that isn't Internet Explorer? If that's not possible, can you post a screencap of your current advanced tab in Internet Options? Also, what version of IE are you using?
    – Derek F
    Aug 4 '16 at 17:22
  • @Derek F , I wish we can but, we're only allowed to use IE. I'm using IE 11 Version: 11.0.9600.18376
    – Sam
    Aug 4 '16 at 19:10
  • Advanced Tab - postimg.org/image/klbzqssi9
    – Sam
    Aug 4 '16 at 19:17
  • IE Info: postimg.org/image/ty1q2f275
    – Sam
    Aug 4 '16 at 19:17
1

From the screenshots you've provided, it looks like the issue may be that you still have TLS 1.0 enabled.

As the link you provided about TLS 1.0 being phased out states, all sandboxes were made to require TLS 1.1 or TLS 1.2 in June of this year (2016).

My knowledge of how browsers and servers negotiate which security scheme to use is basically non-existent (sounds like something we might find on stackoverflow or another stackexchange site).

I'd think that your browser and Salesforce would negotiate to find the lowest acceptable common scheme (TLS 1.1 in this case), but perhaps the very act of suggesting TLS 1.0 as a possibility is causing Salesforce to flat out reject the connection.

Try disabling TLS 1.0, and trying to log into your sandbox again.

1
  • Yes, allowing TLS 1.0 can allow a downgrade attack. It must be completely disabled.
    – sfdcfox
    Aug 25 '16 at 11:30
0

I faced the same issue last week while using Salesforce sandboxes in Google Chrome and even though TLS 1.1 and 1.2 was enabled AND TLS 1.0 was disable in Advanced Internet Options, the error persisted. It also didn't let me connect Eclipse with and Salesforce orgs. The strange thing was, I didn't get this error in IE 11 or Edge.

The only possible solution which I know so far and which also worked for me was, to "Reset" the settings. To do that, go to

Control Panel -> Internet Options -> Advanced Tab -> Click "Reset" button at the bottom.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.