2

I am using Force.com IDE-Eclipse Mars and jre7. I have added -Dhttps.protocols=TLSv1.1,TLSv1.2 in Eclipse.ini ,but still I am getting this error.I am trying to fetch data from Sandbox.

What am I missing here?

Also,when I am entering wrong password,I am getting error: Invalid username,password,security token or user locked out.

1
  • I have disabled TLS1.0 and enabled TLS1.1 and TLS 1.2 in advanced security settings. and I am using -Dhttps.protocols=TLSv1.1,TLSv1.2 in eclipse.ini.Still,I am getting the same error.Can any one tell what could be the problem Commented Aug 30, 2016 at 10:55

2 Answers 2

2

To ensure that TLS 1.0 is successfully deactivated, you can hit this URL in browser and check: https://tls1test.salesforce.com

Also, these are the two steps you need to follow, if TLS1.0 is still active: To fix this issue in Eclipse -

1) Update your eclipse.ini file to include this line: -Dhttps.protocols=TLSv1.1,TLSv1.2 You will find eclipse.ini file in eclipse installation directory.

2) If you are using Java 7, then you need to disable TLS1.0 and enable TLS1.1 and TLS1.2. (GO to control panel --> Java --> Advanced --> Advanced Security settings). TLS 1.0 is disabled by default in Java 8.

7
  • More details: help.salesforce.com/HTViewSolution?id=000221207
    – Deepish
    Commented Aug 30, 2016 at 9:15
  • Hey Deepish,I have disabled TLS1.0 and enabled TLS1.1 and TLS 1.2 in advanced security settings. and I was already using -Dhttps.protocols=TLSv1.1,TLSv1.2 in eclipse.ini.Still,I am getting the same error. Commented Aug 30, 2016 at 9:28
  • What is the result when you hit the URL in browser: tls1test.salesforce.com ?
    – Deepish
    Commented Aug 30, 2016 at 9:41
  • TLS 1.0 Deactivation Test Passed Commented Aug 30, 2016 at 9:53
  • Do you have another salesforce org to try out? Seems like TLS is not the problem here, but the credentials is.
    – Deepish
    Commented Aug 30, 2016 at 9:56
0

After adding -Dhttps.protocols=TLSv1.1,TLSv1.2 it is working for me. please check the java version it should be grater than 1.7

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .