0

I am integrating a .NET web application with Salesforce via the Partner WSDL and SOAP API.

I am currently getting an error

UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.

I know that I can go

Setup > Critical Updates > Deactivate the Require TLS 1.1 or higher

But what is the downside to this? I mean will they stop allowing us to deactivate it at some point?

How can I make my client application use TLS 1.1 or higher?

Edit:

Here is a part of my app.config. The project is a sample Console application just to test integrating with the SOAP API.

<startup> 
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.6.2" />
</startup>

I found the solution. In my code I set

System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls11 | SecurityProtocolType.Tls;

as per https://help.salesforce.com/HTViewSolution?id=000221207

1

You can disable the feature for now, but it will be required within the next five months or so (March 2017 for production orgs). This is because TLS 1.0 is considered "broken" and should not be used to protect data anymore. Your code will not able to communicate with any salesforce.com org as of early spring next year.

To upgrade your TLS capabilities, you need to upgrade to .NET 4.5; you can use the SslProtocols enumeration to select TLS 1.2. The exact method will vary, but the MSDN documentation should give you all the information you need.

| improve this answer | |
  • The target .NET framework for the application which calls the API is 4.5.2 but I still get this error – andrewb Nov 14 '16 at 18:32
  • @andrewb You need to modify your code to use TLS 1.2. Clearly, the code is explicitly asking for TLS 1.0, probably as an artifact from when it was originally developed, assuming it's a few years old. You need to check your code and/or any config files you may have. Without being able to see the source, it'd be hard for us to tell you exactly what to do, but the main point of my answer is you must do it or your application will cease to work. You've got a few months to figure this out, though. – sfdcfox Nov 14 '16 at 18:34
  • I added the supported runtime from app.config – andrewb Nov 14 '16 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.