1

Does TLS update have any impact in apex Data loader? If it so, in what way will it affect? What measures has to be taken in order to use Data loader after that update?

  • 1
    In case the answers were not clear enough, what you need to know is that all Apex Data Loader installs before Spring '16 will no longer work without upgrading the software. – sfdcfox Apr 27 '17 at 13:15
  • @sfdcfox- Spot on Sir! – Samir Apr 28 '17 at 4:52
2

The Salesforce Article on TLS 1.0 Disabling explicitly has a section on Data Loader for you at

https://help.salesforce.com/articleView?id=Salesforce-disabling-TLS-1-0&language=en_US&type=1#DataLoader

which states

To ensure no disruption to the use of Data Loader, customers need to download the newest version of data loader, released with Spring '16, which is the only version that supports TLS 1.1 and higher.

2

The Spring 16 release of DataLoader has support for TLS 1.2.

Starting in the first quarter 2016, Salesforce will begin disabling the TLS 1.0 encryption protocol. After Salesforce disables TLS 1.0, any inbound connections to, or outbound connections from Salesforce will need to use the TLS 1.2 encryption protocol. This change impacts API-based software that Salesforce makes available for download, such as Data Loader. The Spring '16 version of Data Loader has been enhanced to support TLS 1.2.

To maintain access to Data Loader, you must upgrade to the Spring '16 version of Data Loader and Java JRE 1.8. We recommend that you begin planning to support TLS 1.2 as soon as possible

See Salesforce disabling TLS 1.0​ : Salesforce disabling TLS 1.0

Also from Salesforce Spring ’16 Release Notes - Data Loader

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.