2

In our system, there were multiple Organization-Wide Email Addresses configured and verified. In that I need to make one default address as "From Address" to everyone. Eg: support@xxx.com.

I am trying to execute the following Javascript code in custom button

location.replace('/email/author/emailauthor.jsp?retURL=/{!Case.Id}&p3_lkid={!Case.Id}&rtype=003&p2_lkid={!Case.ContactId}&template_id=00XCXXXXXXXXXXX&p26=support@xxx.com');

It is working fine for almost everyone. But for only one user from address is not picking the correct address. What might be the issue with that user? Where I need to set this Default from address? Whether the effected user might have changed his email settings? Debugged in the possible ways, but couldn't able to figure out the issue.

  • Have you checked the console for errors? – Berg Jul 20 '15 at 19:21
  • Yes. That is what happening now @Seesh – Salesforce Developer Jul 20 '15 at 19:29
  • @SalesforceDeveloper Deleted comment because I thought of rephrasing the question. So the email is sent. The affected user is in a different profile or is it working for other users in that profile? – Seesh Jul 20 '15 at 19:33
  • @Seesh It is working for other users in the same Profile. I have seen only one user who is getting other different address. – Salesforce Developer Jul 20 '15 at 19:36
  • 1
    @SalesforceDeveloper Because when you set the OWD email address, you have an option for selecting all or particular profiles to use that FROM address. – Seesh Jul 20 '15 at 19:37
0

Raised this concern with Salesforce Support. Here is their reply.

Email address passing in the URL using p26 parameter (From address) is considered as URL hacking which is not supported. However if you can use the below format of passing from address in the button click javascript code, which seems will resolve the issue.

&p26=ORG_WIDE_EMAIL_ADDRESS_RECORD_ID:Email Address:Display Name

Example:

&p26=0D2XXXXXXXXXXXX:care@xyz.com:XYZ Support

Absolutely it's working fine without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.