0

I am trying to add a survey to community but there are no communities listed for setting as default for survey. The selection drop down shows 'None'

I am trying on developer org and my community is active and published. I have granted access to Surveys, Survey Invitations and Survey Response objects to Guest user profile for community.

enter image description here

0

I was able to recreate this issue in my developer org. Here is what I did

Step 1: Went to Setup >> Survey Settings >> Enable Surveys and noticed that 'Select the default community for creating public survey invitations' does not have any values

enter image description here

Step 2: Checked list of all available communities from Setup >> All Communities and noticed that they are in Preview state

enter image description here

Step 3: Activated 'E-Bikes' community by clicking Workspaces > Administration

enter image description here

Step 4: Refreshed the survey settings page and observed that 'Select the default community for creating public survey invitations' shows the active community

enter image description here

Verified this in another developer org where I have enabled surveys already and observed that the list shows only active communities

enter image description here

enter image description here

Based on my observation, the only criteria for 'Select the default community for creating public survey invitations' to display results is that the community should be active. If the community is already active and does not show up in the list, I recommend raising a support case. Also, you might want to check if it is a site or community and ensure you are activating the community

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.