1

I have a community for surveys. I made its home page public and set the community itself to be accessible to the public. I verified that the homepage is accessible to the public. I set the survey settings to use this community.

The URL I generate for participants outside gives me an error:

Page Not Found: /aura

This is the link:

https://xxxxxxxx.force.com/survey/survey/runtimeApp.app?invitationId=0Ki1o0000008RFU&surveyName=xxxxx&UUID=63956eb5-86ef-4b21-b178-6ba05a865843

Do you need to add any page to the community for the survey to show up? Do I need to give the guest user any special permission for the survey to show up?

2

I tried following the steps mentioned here- https://techiesexpress.blogspot.com/2020/12/how-to-embed-survey-component-in.html and I was able to make it work. Check if that helps!

Pre-requisites

  1. Go to Setup-->All Community and create a new community by choosing any template.

  2. Once the community gets created, click on the builder.

  3. In the builder, click on the gear icon and then click on the guest user profile.

  4. Edit the guest user profile and provide Read Access on Survey and Survey Invitation objects and Read, Create and Edit on Survey Response Object, and save.

  5. Then in the community builder click on the publish button on the top right to get your community published.

  6. Now go to setup --> All Community --> Open workspaces for the community you just created, open Administration, and click on "Activate Community"

  7. Once your community is activated, add it to survey settings by going to setup --> Survey Setting and add as below under "Select the default community for creating public survey invitations."

  8. Once the community set-up part is done, create a Survey, and activate it once done.

  9. Open the Survey builder for the above Survey and generate the default Survey Invitation URLs for "Participants outside your company"

Notice- The invitation URL domain is the same as your default community domain which you had set in the Survey settings in step 7.

** Also if you want guest users to take that survey, then 'Check' the option 'Don't require authentication'

  1. To embed the survey in your community pages, go to setup --> All Community --> Open workspaces for the community you created above and open the builder.

  2. In community builder, click on the first lightning icon on the top left and type survey in the search bar.

  3. Drag and drop the Survey component to the block you want to place it, and then choose the Survey name (of the Survey you created above) in the component configuration details.

  4. Now click on the publish button on the top right to save the new changes.

  5. Open the community page in runtime and you will be able to see the survey component rendered on your community in runtime.

Note- If you try to embed the same survey in a different community, ensure you repeat steps everything again from step 6 as the default survey invitation URL is needed for each community domain you want the survey to be embedded into.

3
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – identigral
    Nov 29 '20 at 16:09
  • @identigral sorry, I did not understand, I am very new here, can you please explain a bit more? Nov 30 '20 at 10:26
  • 1
    @identigral understood from the link you provided, will ensure to add the link/blog contents instead of just providing the link, thanks for pointing that out. Nov 30 '20 at 10:30
1
1: From Setup, enter Survey in the Quick Find box, then select Survey Settings.
2: Check which community is selected as the default community for creating public survey invitations.
3: Enter Communities in the Quick Find box, then select All Communities.
4: Open the Community Builder of the default community.
5: From Community Builder, click the Settings icon, and select General.
6: Click the profile name under Guest User Profile.
7: Click Edit.
8: In the Standard Object Permissions section, provide guest users the following permissions:

I found this its working.

FirstStep SecondStep ThirdStep FourStep LastStep

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.