0

I created a Journey in Child BU that uses SF Object Contacts as entry and trigger whenever a Contact Is created. So i tested creating contact and see if it is being accepted under the Child BU JB, but its seems that is it not being injected and accepted. I have setup the MC configuration in SF on choosing the parent and child BU. What could be the reasons as to why the contacts are not being injected on the child JB? Is it possible to inject SF Contact Object to Child BU? Multi Org is not turned on the Account.

My Entry Criteria as Follows:

WHO Contact ID (Contact) OBJECT Contact ACTION Created; CRITERIA Contact:Id WASSET AND Contact:Email is Not Null

9
  • Have you tried injecting it in a master BU journey? The reasons for contacts not injecting can be manifold – Stephan de Paly Jul 27 '18 at 19:41
  • Is child BU integrated using marketing cloud connect as the same master BU SF Org? – Vijaya Kapadam Jul 30 '18 at 0:20
  • @StephandePaly i tried it in Master BU and it works fine. It cant be manifold cause im using a controlled data for the purpose of testing. During the test it was only being injected on the Child BU JB but it was not accepted. I recreated the test in main BU and it was accepted. What could had been wrong, that it is being prevented to be injected in child BU JB? – m.dacillo Jul 30 '18 at 3:25
  • @Plug SF is only integrated in Main BU as multi-org is not enabled. Child BU should inherit the setup in the Main BU. – m.dacillo Jul 30 '18 at 3:27
  • @m.dacillo Can you check Journey history tab and filter your journey and see if you can narrow down issues? Do you see any logs there at all? – Vijaya Kapadam Jul 30 '18 at 3:30
0

When working with Multiple Business Units, Single Org Connector and Marketing Cloud Connect, you need to make sure that:

  • The MC Integration User has access to All Business Units
  • The SF Integration (API) User has access to all Business Units
  • The Connector is configured with all the desired Business Units

Doing the above ensures that the oAuth connection is intact across BUs and journey injection can happen.

If the above is done, and it still doesn't work - then as you write in the comments - clearing tokens might be needed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.