1

I have data extension where I have defined two fields as primary key (tested with one key as well) and DE added to contact builder. We send lot of emails daily and this is our normal drill.

But some how for this DE when I fire event no contact added to journey builder and when I view event results I can see all the contacts evaluated for journey, none accepted (all rejected), rejected contact view show status "DidNotMeetEntryCriteria" there is no entry criteria or filter.

I tried many options adding DE to attribute group, tried to inject without adding to attribute group, creating a simple journey without any email in the journey. But every time I get status it is either "Failed" or "DidNotMeetEntryCriteria" I have no entry criteria and selected correct email for the journey if I am using email in the journey.

Please let me know if anyone have have knowledge of this issue.

Best

  • Is the Data Extension mapped to the Contact Key in Contact Builder correctly? – C Carswell Dec 7 '16 at 3:23
  • Yes it does as I said I have tried to map/connect with as single PK as well as two fields as PK in DE. – F.Dell Dec 7 '16 at 7:28
  • I have also faced same issue but now its working fine. salesforce.stackexchange.com/questions/149808/… – Palash Rai Dec 7 '16 at 7:51
  • Also, did you create Population and Contacts Configuration in Contact Builder? – Palash Rai Dec 7 '16 at 7:56
0

I also experienced this problem and according to salesforce engineers it was caused by an issue in the contact data model. If this is the problem, I'm afraid you need to reach out to salesforce support team. A fix will be released on 27th January (Release Notes: January 2017 Release).

Here you can find the possibly related issue: 'Contacts Registration Failed' Marketing Cloud Connect error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.