0

i have created a send able DE with mobile number and i am using same DE as a entry source in the Journey builder,

created Outbound SMS with personalization.

In Journey builder i have configured the SMS send activity. activated the journey immediately, but not got any SMS.

i have checked in Event Result of the entry source, it is showing contact evaluated =5 Contact accepted =0

Attached screenshot.

Can you suggest, where i am doing wrong or procedure and rules to use mobile connect SMS in journey builder.

enter image description here

  • have you imported you mobile audience? – Samuel Dare Sep 21 '17 at 15:59
  • yes manually imported to the DE. – Ranjith Haridas Sep 21 '17 at 18:11
  • Just now again i have checked the Event Result of the entry source, it is showing contact evaluated =10 Contact accepted =6 – Ranjith Haridas Sep 21 '17 at 18:17
2

First check your DE attribtues. The DE should contain Subscrirbey key with Text as datatype, an email address with an email address as datatype and a phone number field.

In the send relationship, subscriber key should be related to "All subscribers"

Next step, Configuring journey SMS activity.subscriber opt-in choices

If you have selected, Send only to contacts who are subscribed currently, then you need to create a mobile contact list and loaded all your mobile numbers, locale and subscribed to a keyword or You can choose Subscribe all Contacts to a keyword. This will subscribe contacts’ phone numbers in real-time to a keyword of your choice as they hit the activity.

The last step, Make sure you have chosen the correct phone field in the journey settings.

Note: Your phone number should also contain the country code. Example: Singapore country code: 65 Mobile Number: 9898 9898 so Valid phone number is: 6598989898 enter image description here

  • i have done all this, but still not receiving the SMS, – Ranjith Haridas Sep 22 '17 at 11:49
  • Can you just test the outbound sms in Mobile connect? Is it working there? – Praveen Kumar Bandi Sep 22 '17 at 13:54
0

I found solution for this, before sending SMS via Journey builder,

Step 1- mobile numbers should be present in mobile connect

Step 2- There is a Locale field in mobile connect which should be specified in the DE eg:- https://countrycode.org/

these two are main solutions to use Mobile connect SMS in Journey Builder. remaining regular configuration in Journey Builder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.