6

Trying to install Force.com IDE and I am getting the following error in Eclipse:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide_29.0.0.201310181333.jar.
Read timed out
Unable to read repository at http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide.api_29.0.0.201310181333.jar.
Read timed out
Unable to read repository at http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide.core_29.0.0.201310181333.jar.
Read timed out
Unable to read repository at http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide.core.compatibility.auth.equinox_29.0.0.201310181333.jar.
Read timed out

What can be done to resolve this issue?

5

I figured it out!

I had to copy the links that weren't reading the repository correctly and paste them into the search bar on the browser. It downloaded the missing files and then I moved these files into the Eclipse plugins folder. When I ran it again it was successful.

2

Per the installation instructions, if you receive a "read timed out" error, you may need to configure your proxy settings.

Configure Eclipse to use your proxy server. These settings can be found in your Eclipse Preferences, under General > Network Connections.

  • There is no proxy server. I have looked through the ipconfig /all and there is no text next to 'Primary dns suffix'. Anything else I might be doing wrong? – wadams2010 Nov 1 '13 at 18:10
  • After I added my proxy settings, this worked a treat. A good step by step guide on how to do this is here: mkyong.com/web-development/… – Christopher Alun Lewis Apr 7 '14 at 15:00
0

Open eclipse Goto Window Preferences General NEtwork settings Check your proxy settings,if not using proxy,use direct option try again

  • ram, you may want to note that you've posted an answer to a 2yr old question. Also, the user who posted the question later posted an answer with the solution that solved his problem. The solution isn't what you've posted as an answer to his question. – crmprogdev Apr 14 '16 at 13:14
0

For me it was hanging up partway through every time on the same jar. (http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide.core_36.0.0.201601221512.jar)

I manually downloaded that jar and copied to the plugins folder. Next try the install completed.

0

I tried to install at work. Kept receiving an error. So, I disconnected my laptop from my work network, turned on my iPhone hotspot, and all worked per normal. The network was the problem for me.

-Windows 10 -Eclipse Neon.3 -Force.com - https://developer.salesforce.com/media/force-ide/eclipse45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.