2

The version of Eclipse I'm running is : 3.8.1

I'm trying to install the force.com IDE for eclipse. I've seen many threads on this issue, and to be honest I'm so new to ubuntu and eclipse that I'm unable to get this resolved.

I have downloaded the eclipse marketplace as per these instructions https://help.salesforce.com/apex/HTViewSolution?id=000181372&language=en_US . The IDE does not show up in the list when searched for. I can find it when I go to http://marketplace.eclipse.org/search/site/%2522force.com%2520ide%2522 but when I drag the 'install' icon to eclipse I get the following error:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Force.com IDE 36.0.0.201601221512 (com.salesforce.ide.feature.feature.group 36.0.0.201601221512)
  Software currently installed: Eclipse Platform 3.7.0.debbuild (org.eclipse.platform.ide 3.7.0.debbuild)
  Only one of the following can be installed at once: 
    Eclipse UI 3.103.0.v20120705-114351 (org.eclipse.ui 3.103.0.v20120705-114351)
    Eclipse UI 3.8.0.dist (org.eclipse.ui 3.8.0.dist)
    Eclipse UI 3.8.0.v20120523-1546 (org.eclipse.ui 3.8.0.v20120523-1546)
    Eclipse UI 3.104.0.v20121024-145224 (org.eclipse.ui 3.104.0.v20121024-145224)
    Eclipse UI 3.8.2.v20121018-234953 (org.eclipse.ui 3.8.2.v20121018-234953)
    Eclipse UI 3.7.0.I20110602-0100 (org.eclipse.ui 3.7.0.I20110602-0100)
    Eclipse UI 3.103.0.v20120521-2329 (org.eclipse.ui 3.103.0.v20120521-2329)
    Eclipse UI 3.7.0.v20110928-1505 (org.eclipse.ui 3.7.0.v20110928-1505)
  Cannot satisfy dependency:
    From: Force.com IDE 36.0.0.201601221512 (com.salesforce.ide 36.0.0.201601221512)
    To: bundle org.eclipse.ui 3.103.0
  Cannot satisfy dependency:
    From: Force.com IDE 36.0.0.201601221512 (com.salesforce.ide.feature.feature.group 36.0.0.201601221512)
    To: com.salesforce.ide [36.0.0.201601221512]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.8.1.dist-A8F8_IVSG4WGSImg7oLZb9p1HecSFyJZcMPL9 (org.eclipse.platform.feature.group 3.8.1.dist-A8F8_IVSG4WGSImg7oLZb9p1HecSFyJZcMPL9)
    To: org.eclipse.rcp.feature.group [3.8.1.dist-92A7GODFSNQBG]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.0.debbuild (org.eclipse.platform.ide 3.7.0.debbuild)
    To: org.eclipse.platform.feature.group [3.8.1.dist-A8F8_IVSG4WGSImg7oLZb9p1HecSFyJZcMPL9]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.8.1.dist-92A7GODFSNQBG (org.eclipse.rcp.feature.group 3.8.1.dist-92A7GODFSNQBG)
    To: org.eclipse.ui [3.8.0.dist]
1

See this: Force.com_IDE_Installation

Problem

Attempting to install the Force.com IDE generates the following error:

Cannot complete the install because of a conflicting dependency.
Software being installed: Force.com IDE...

Solution

Move Eclipse to a folder other than Program Files. See this thread for more details.

  • 1
    I see you are using ubuntu but the thread i have shared has attached several solution that you can try. – Mr.Frodo Jun 4 '16 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.