7

I'm installing the Force.com plugin for Eclipse but received the error below. I'm using Eclipse 4.2 and I received the same error with 4.3. I tried using an older version of Eclipse, 3.6, but the installation continuously timed out after reaching 10% completion.

Here are the application and error details:

  • Windows 7
  • 64-bit
  • jdk 1.7
  • jre 7
  • Eclipse 4.2 Juno
  • Force.com v29.0

An error occurred while collecting items to be installed session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). Unable to read repository at http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide_29.0.0.201310181333.jar. Read timed out Unable to read repository at http://media.developerforce.com/force-ide/eclipse42/plugins/com.salesforce.ide.api_29.0.0.201310181333.jar. Read timed out

0

Eclipse 4.2 “Juno” and 4.3 "Kepler" are the most recently supported version of Eclipse.
Thanks to ManSpan

  • 2
    well actually 4.2 and 4.3 are also supported with the winter 14 version. I have installed it on Friday wiki.developerforce.com/page/Force.com_IDE – ManSpan Nov 17 '13 at 20:26
  • 2 items from above link mentioned by @ManosSpanoudakis 1. Added support for version 4.2 “Juno” and 4.3 "Kepler" 2. Dropped support for version 3.x – Ganesh Bhosle Nov 18 '13 at 5:15
  • Thats why 3.6 is no more supported from Winter 14. – Ganesh Bhosle Nov 18 '13 at 5:16
  • Wow! Cool! I'll try Kepler. – Andrii Muzychuk Nov 18 '13 at 6:40
  • 3
    Found the solution. This is more of an Eclipse error, whereby eclipse was trying to use IPv6 to connect. See details here: flintstudio.com/blog/…. Simply adding "-Djava.net.preferIPv4Stack=true" to eclipse.ini fixed it. – miCRoSCoPiC_eaRthLinG Feb 9 '14 at 6:20
1

You can start fresh and follow instructions step by step... https://developer.salesforce.com/page/Force.com_IDE_Installation

1

Try downloading Eclipse classic Standard/SDK and update to salesforce plugin with http://media.developerforce.com/force-ide/eclipse42. It worked for me. Once you updated with the force.com plugin, you can later update the eclipse sdk to the latest version if needed.

http://www.eclipse.org/downloads/index-helios.php http://www.eclipse.org/downloads/packages/eclipse-classic-42/junor

0

Try to install force.com ide from below link

http://media.developerforce.com/force-ide/eclipse42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.