3

I am trying to install Force.com IDE on eclipse.Meanwhile i am facing some issues with it Version: Helios Release Build id: 20100617-1415

Cannot complete the install because one or more required items could not be found. Software being installed: Force.com IDE 29.0.0.201310181333 (com.salesforce.ide.feature.feature.group 29.0.0.201310181333) Missing requirement: Force.com IDE 29.0.0.201310181333 (com.salesforce.ide.feature.feature.group 29.0.0.201310181333) requires 'org.eclipse.core.runtime 3.8.0' but it could not be found

Any idea how to resolve this issue?

2

API Version 29 is Winter ’14 and Eclipse versions 3.x are no longer supported. From Force.com IDE - What’s New in Winter ’14:

Version 4.2 "Juno”
Note: The Winter ’14 release no longer supports Eclipse version 3.x. If you rely on Eclipse 3.x, you can use an older version of the Force.com IDE, but older versions will not be updated with the latest metadata enhancements.

So, you can install a previous version if you need to use an Eclipse version 3.x, but you will not have access to API version 29 or you can install (or upgrade) to a newer Eclipse version and have access to API version 29.

Look at the updated installation instructions for the detailed step-by-step installation instructions for the API Version 29 IDE.

My answer in this question describes how to install a previous version of the IDE if you choose to do that (see relevant portions below):

From Eclipse you can follow the normal Force.com IDE Plugin instructions, except you can choose to not Show only the latest versions of available software.

  1. Help | Install New Software...

  2. Click Add.. button to add a new site.

  3. Call It Force.com IDE and give it the value of http://www.adnsandbox.com/tools/ide/install/ and click OK.

  4. Untick the Show only the latest versions of available software

Expand the Force.com IDE node and you'll see that there are the previous versions

IDE pic

Note the Installation URL in step #3 is http://www.adnsandbox.com/tools/ide/install/ and NOT http://media.developerforce.com/force-ide/eclipse42 for older versions of the IDE.

0

There are actually two problems during installation Force.com IDE Plugin in eclipse:

i think you are following the guide as of the link below:

Force.com eclipse 3.6(Helios) installation

  1. if you are connected to internet eclipse will automatically download all the dependent packages required else you need to manually do it.

  2. Sometimes in windows 7 UAC settings might not allow eclipse to update for this you have to move eclipse out of your program files folder as discussed here...

Windows 7 Force.com IDE installation issue

-1

try these steps..

  1. Uninstall Force.com IDE
  2. Upgrade Eclipse
  3. Reinstall Foce.com IDE..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.