4

I am getting the following error when I try to refresh my project or create a new project in the force.com ide

Destinaton URL not reset. The URL returned from login must be set in the SforceService

My username and password are correct and I have verified that my IP is included under setup -> network access.

This is only happening for one org on cs9. My eclipse projects for other orgs are working without any issues.

2

I've seen this a few times in Eclipse, so far the best solution I've found is to simply restart Eclipse—seems to fix it every time.

I've had the issue occur seemingly randomly, even on a project I've been working on for a few hours it'll sometimes just start throwing this up every time I try and save to server.

  • This is what I ended up doing but I'd like to leave this open for a bit to see if someone comes along who knows why this happens and what you can do to avoid it. – Greg Grinberg Dec 7 '12 at 20:33
1

This is happennig because Salesforce has disabled TLS 1.0 encryption.

After June 25, 2016, at 9:30 AM PDT (16:30 UTC), all sandbox orgs -- whether existing, refreshed, or new -- will have TLS 1.0 automatically disabled and will require TLS 1.1 or later in HTTPS connections to or from the sandbox org.

For more information on Salesforce disabling TLS 1.0 refer - https://help.salesforce.com/apex/HTViewSolution?id=000221207

To fix this issue in Eclipse -

1) Update your eclipse.ini file to include this line: -Dhttps.protocols=TLSv1.1,TLSv1.2 You will find eclipse.ini file in eclipse installation directory.

2) If you are using Java 7, then you need to disable TLS1.0 and enable TLS1.1 and TLS1.2. (GO to control panel --> Java --> Advanced --> Advanced Security settings). TLS 1.0 is disabled by default in Java 8.

For Data Loader -

1)Uninstall older version of Data Loader and install Spring '16 version of Data Loader.

2) Install Java JRE 1.8.

Note:- Salesforce is going to disable TLS1.0 protocol on Production orgs in March 2017. So before salesforce disables TLS1.0, all the channels which are communicating to salesforce need to use TLS version 1.1 or higher.

-1

Check to make sure that you set the correct org type: sandbox/production, development, config, etc.

  • That was not the issue. I had it pointing to the correct endpoint. – Greg Grinberg Dec 7 '12 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.