15

I updated my Salesforce IDE to the last version (Summer 14 / APIv31) this week and I noticed some issues when saving apex classes that contains characters with accentuation. For example, strings like "não" where saved "n?o", but I only noticed that when I saw the code in browser or updated the class in the IDE via refresh from server.

Doing some research, I discovered a new feature related to the tooling API: https://developer.salesforce.com/page/Force.com_IDE

Set the Tooling API as the default mechanism used for Apex classes and triggers, and for Visualforce pages and components.

When disabling this feature, the issue with accentuation does not occur but the IDE continuously syncs with the server. When re-enabling the feature, the syncs stop and the issue with accentuation comes back.

Anyone had issues with accented characters with the new SFDC IDE?

Update:

I reproduced the issue using a new installation of eclipse + SFDC IDE plugin. Here are the steps:

1) Download de eclipse IDE Kepler version

2) Install the lasted version of the SFDC IDE (v.31)

3) Create a project pointing to a sandbox server. In my case was at CS16.

4) Create a class Test.class

5) Add a comment:

public with sharing class Test {
 // não
}

6) Save the class. As the IDE is configured to work offline, I need to save the class using the menu Force.com -> Save to Server.

7) I opened the class via browser, and the comments are ok (no issue with accentuation)

8) Change the project to work on-line

9) Modify the class

public with sharing class Test {
 // não aáoó
}

10) Save the class. Now the class is saved automatically to the server.

11) Checking the class again via web, the accentuation is lost.

public with sharing class Test {
 // n?o a?o?
}
  • 2
    For what it is worth, I don't think it is specifically the Tooling API causing the issue. I'm able to update an ApexClassMember.Body using the Tooling API with a //não comment and it round trips with the correct encoding. It might be related to the string encoding Eclipse is using to set the Body. – Daniel Ballinger Jul 30 '14 at 22:52
  • 3
    I've had a ton of issues with Eclipse and I've found to MavensMate to work a lot better.. Ever since it went open source I'm excited to see what the open source brings, but until then ill stick with mavens – EricSSH Jul 31 '14 at 5:57
  • I updated the question with some steps on how to reproduce the issue. I hope that someone could confirm this. Thanks. – Mimica Aug 1 '14 at 0:01
  • 1
    I believe this is the same issue: [link] (success.salesforce.com/issues_view?id=a1p30000000T2hoAAC) – Mimica Aug 1 '14 at 14:07
2

You can use another IDE for the Force.com instead of Eclipse . Here you can go for the Sublime Text Editor and Use MavensMate plugin.

Installation Steps --

Step 1 - Download the Sublime Text Editor according to your operating system by clicking below link :

http://www.sublimetext.com/2

Step 2 - Download the Mavensmate Plugin for the sublime editor

http://mavensmate.com/

Step 3 - Installation Guide For the Mavensmate who did'nt ever used this in sublime for Salesforce Project. Sublime Text Package Control must be installed:

https://sublime.wbond.net/installation

1)Open Sublime Text 3 (Sublime Text 2 no longer supported)

2)Run Package Control: Install Package command

3)Search for MavensMate

4)Hit Enter

Step 4 - Configure your Salesforce Project in MavensMate .

Note : After Setup, Follow your given above process, I am sure that this time you will get no problem regarding your issue.

0

As an alternative answer to Amit Agrawal's answer (which is great, btw), here are the steps for using Atom with MavensMate (I prefer Atom to Sublime myself, but ymmv)

Installation Steps (OS X Only due to a bug in the MavensMate Plugin)

  1. Download atom.io
  2. Drag "Atom" to Applications folder
  3. Launch Atom
  4. Select "Preferences" from the menu options under "Atom" cmd+,
  5. Click on "Install"
  6. Type "MavensMate" into the search, hit enter
  7. Click on the blue "Install" button on the MavensMate-Atom package

Under the MavensMate menu option, use "New Project" to pull down your SFDC code to start developing locally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.