0

I have extracted the metadata of a community from one sandbox, (network, site and siteDotCom and all other relevant such as Lightning components) and have deployed them with ant in another sandbox. When I go to the newly created community in the target sandbox and try to access the builder the following error occurs in chrome: enter image description here

if I click close, the builder is loading indefinitely. The error in firefox and safari is a little more detailed: enter image description here

So far I have tried the following but nothing resolved the issue - Flushing my cache - Different browsers - Publishing the community and trying again - Renaming the community to remove any spaces from the name - Searching for the term 'Branding' and 'def' in the metadata deployed, nothing appears - Trying to find the custom branding, can not edit it as the builder loads indefinitely.

Any suggestions ?

1

I ran into the same issue deploying Community Metadata. The only solution I have found so far is to first create a blank community in the target org matching the name and url of the one you want to deploy. After if I only deployed the necessary Network, NetworkBranding, CustomSite, SiteDotCom, custom Lightning Components, and any custom Apex Class Controllers metadata, then I was able to view the builder for the community in target org.

Hopefully this helps!

  • Thanks @kgutierrez! We resolved it by refreshing our sandbox and thus getting the community from the Production org. Then we deployed the changed components with no issue of the community builder. The builder is a still clunky, I think there are a few improvements that should take place. – Antigoni Jan 4 '18 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.