1

We are trying to push experience bundle, sitedotcom , network , site via azure devops to another sandbox and other environments. The problem we face is everything looks fine in the git branch. But when we are deploying it throws the error as in below:

File            Type                  Error   

ABC.site      Site.Com   You seem to be missing site. Add the file to your bundle and try again.

Below is package XML which we are trying to push:

 <types>
        <members>ABC</members>
        <name>CustomSite</name>
    </types>

    <types>
      <members>ABC</members>
        <name>ExperienceBundle</name>
    </types>
    
    <types>
        <members>ABC</members>
        <name>Network</name>
    </types>
    
     <types>
        
        <members>ABC</members>
        <name>SiteDotCom</name>
    </types>
    

As per salesforce documentation,

https://developer.salesforce.com/docs/atlas.en-us.communities_dev.meta/communities_dev/networks_migrating_from_sandbox.htm#!#:~:text=Deploy%20Your%20Experience%20Cloud%20Site%20with%20the%20Metadata,data%20and%20deploy%20it%20to%20your%20production%20org.

It was mentioned that :

ExperienceBundle or SiteDotCom—If you’re deploying an Experience Builder site, we recommend using ExperienceBundle instead of SiteDotCom. ExperienceBundle provides text-based representations of the different Experience Builder settings and site components, such as pages, branding sets, and themes, that make up an Experience Builder site.

We tried all possible scenarios but could not find solution, does anyone have any solution on this?

2
  • 1
    You will need to remove the site.com that's not needed if you have experience bundle enabled. Nov 2, 2021 at 23:26
  • Hello Mohith, I have commented out the SiteDotCom in the package.xml, and have kept only the experience bundle , custom site and network and tried to validate with the target sandbox. But it still throws the same error. I tried the other way around, by commenting out the experience bundle and keeping custom site, siteDotCom and network in the package. This time it is success. But this will not deploy my community pages from the bundle right?.
    – Ajay
    Nov 3, 2021 at 9:55

1 Answer 1

0

I had the same issue and didn`t find anything else besides your 2 questions (here and trailhead forum).

So, I decided to leave the answer here, maybe it will be useful for others.

In order to deploy experience via mdapi with ExperienceBundle make sure your package.xml looks like the one below:

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>*</members>
        <name>CustomSite</name>
    </types>
    <types>
        <members>*</members>
        <name>ExperienceBundle</name>
    </types>
    <types>
        <members>*</members>
        <name>Network</name>
    </types>
    <version>53.0</version>
</Package>

Also, use 53.0+ version because config/nativeConfig.json isn`t supported by previous versions.

Then make sure you deploy experiences, networks, and sites folders within src.

experiences/ folder must contain brandingSets, config, routes, themes and views folder with respective files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .