I created an Experience Site in a developer sandbox. Once it was ready, I deployed the experience Bundle, Site, Network and all related metadata (LWC, Aura Components, Classes, Fields, etc.. ) to a partial sandbox for UAT testing.

Everything is there and looks good in the experience builder with all the proper settings.

When I try to publish the community from the builder or through SFDX command, I get the following error:

An error has occurred while processing your request. The salesforce.com support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience.

Thank you again for your patience and assistance. And thanks for using salesforce.com! Error ID: 2074602639-22792 (1715759908)

I have compared the two communities / settings etc. between the sandboxes and they are identical. I also have researched for similar issues online but have not found this error id and nothing I have tried seems to work.

Has anyone run into this issue before? Do you how to fix this so I can successfully publish the Experience Site?

  • You should report this to Salesforce Support.
    – Phil W
    Apr 2, 2022 at 14:20
  • 2
    I opened a ticket with Salesforce Support. Hopefully they can generate some logs, but from my experience, they never help. I wanted to reach out to the community to see if anyone experienced this and also will post an answer here if / when I resolve
    – Z33dawg
    Apr 2, 2022 at 14:25
  • This is also happening to me, exact same problem, when migrating from one ORG to other ORG.
    – Fof
    Apr 2, 2022 at 16:37
  • what template? Is it a build your own (LWR) template? Apr 2, 2022 at 17:57
  • In my case Build your Own (Aura)
    – Fof
    Apr 2, 2022 at 18:02

2 Answers 2


Salesforce Support got back to me and they said that this was most likely caused because during the deployment, Navigation Menu Item records were created without having a DraftRowId set.

As a solution:

perform the following query and see if there are any records that are returned.

SELECT DraftRowId,Id,Label,NavigationLinkSetId,NavigationLinkSet.NetworkId,ParentId,Status,Target,Type 
FROM NavigationMenuItem 
WHERE Status = 'Live' AND DraftRowId = null

If there were records returned, delete them. Once I deleted them, I was able to successfully publish the site in the Experience Builder.

You can verify that the Navigation Menu Items belong to your experience by comparing the NavigationLinkSet.NetworkId to the NetworkId for your Experience Site.


Thanks it worked for me aswell.

If you want to see on which community you're deleting the navigation menu item from you can add this field to the SOQL NavigationLinkSet.Network.Name.

So : SELECT DraftRowId,Id,Label,NavigationLinkSetId,NavigationLinkSet.NetworkId,ParentId,Status,Target,Type,NavigationLinkSet.Network.Name FROM NavigationMenuItem WHERE Status = 'Live' AND DraftRowId = null

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .