0

I have created a journey and associated an entry source to it. But now I would like to edit the entry schedule in entry source and it won't let me change it. I can see editing the entry source's schedule time is possible but after saving changes are not taking effect.

I have detached the entry source from journey and tried editing it. not possible.

I have tried copying to entry source and creating a new one but not able to delete the previous one, or the newer one.

Is there a way to delete the entry source, there is a delete button but when i hit delete nothing happens.

5
  • 1
    Are all journey versions using this entry event already stopped and don't have any remaining contacts in it? – Markus Slabina Jan 29 '17 at 9:36
  • This event source is not used by any other journey and just to point out I have also created a test event and tried deleting it but had no luck deleting it also. – pragyanshu kukreti Jan 29 '17 at 10:48
  • Is there any message visible in your browser's developer tools network tab when inspecting the route that is called on deletion? Usually the direct response of the api-route in the background gives more helpful information than the marketing cloud user interface. – Markus Slabina Jan 29 '17 at 10:55
  • Hey in your previous comment I figured out a way and it worked. I went in to the newly created entry source and reedited it and this time I deselected the data extension selected and then tried deleting the entry source.. and tadaa.. it was deleted.. but wondering if it is possible to edit the entry source which I selected earlier? it s not editable as it shows 1 interaction even after I have removed it from the original journey – pragyanshu kukreti Jan 29 '17 at 10:58
  • 1
    I had a similar issue once and stopping the version using the event and creating and saving a new version of the journey without an entry event made the entry event edit- and deletable. Hope this helps. – Markus Slabina Jan 29 '17 at 11:50
1

All I was trying to do was to edit my entry source not create a new version, and fortunately I found a solution by creating a temporary entry source.

As the journey was already a draft, I detached the entry source without creating a new version and attached the temporary source to the journey and when I did that. the original entry source was editable as it was showing 0 interaction and issue was resolved.

Hope this helps people :) Thanks for all your efforts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.