1

I've more or less successfully configured two custom platform activities for Desk.com as per Custom Activities - Desk.com API.

They both appear in the journey builder activities:

Custom Journey Builder platform activities

After configuring an additional journey builder activity there is no change to the available Activities. enter image description here

The newest ExactDev activity differs in that the Endpoint URL is to our own testing server: https://exactdev.company.com/CasePage (changed the domain to 'company' as I'd prefer the dev server not get picked up by bots). It was created following the steps in Defining our Activity App Extension (still in App Center). The key was also changed to be unique.

I confirmed that:

Still, there is no sign in the web servers logs that a request has come in from ExactTarget for the config.json file when Journey Builder is opened for an interaction.

In Chrome's developer tools network tab I can see an indirect request for the config.json file for each of the Desk.com activities. enter image description here

I tried manually creating the same request for my Endpoint URL: https://jbinteractions.exacttargetapps.com/configjson/https%3A%2F%2Fexactdev.company.com%2FCasePage

With this the GET request did appear in the web server logs from an IP address that whois identifies as ExactTarget.

2015-04-01 20:37:19 192.168.1.1 GET /CasePage/config.json - 443 - 68.232.203.57

Incidentally, I learned at this point that the site needs to be SSL on the default 443 port. Previously it was SSL over another port but the ExactTarget /configjson/ request would error out.

1

I found it.

When editing the Journey Builder Activities the Public Extension setting is hiding down the page.

enter image description here

I needed to change it from "This extension is available for: Only this application" to "This application and other installed applications".

enter image description here

Also, make sure you are using the default SSL port 443.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.