0

I have a sendable DE, which has a Phone and a locale field. I want to send SMS to only the numbers that are present in the Data extension. The last time I tried to send the SMS to the contacts present in the DE, a msg was observed to be sent to a contact whose number was not the one present in the DE. Can anybody please guide me on how to ensure only those numbers present in the DE get the SMS; Also if you can point out some of the best practices while handling MobileConnect and SMS in SFMC. Thank you!

1 Answer 1

4

The issue is that the mobile number for a subscriber in your sendable DE is different than on the Mobile Connect. You should always have a process to update the mobile number in Mobile Connect and keep it in consistent with your Master DE( or the system that holds the source of truth) which contains data for your customers.

There are various points to consider when it comes to best practices for Mobile Connect:

1.Manage Consent: Always have the consent updated in MobileConnect, if you are using a different mechanism for Opt Out (customer self service, external link) instead of the STOP keyword

2.Handling Re-subscription: Always have a mechanism for re-subscribing the contacts in Mobile Connect. This is crucial, if a opted out subscriber re subscribes though other means and will still be opted out in Mobile Connect and not receive SMS.

3.Update Mobile Number: This is the issue with you right now. Consider solving the scenarios if a user updates the mobile number, this should be reflected in 'Mobile Connect' (All Contacts screen).If you are sending SMS using JB, then choose the default phone number attribute correctly in the journey settings.

enter image description here

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .