6

I am using a link in a workflow email to a custom object in SFDC1 Salesforce1 Link:

`com.salesforce.salesforce1://entity/view?entityId={!Tradeshow__c.Link}`

I'm getting a error

The page you are trying to access is not supported on mobile devices

However I can search for the account and access the Tradeshow in the account in SFDC1. Is there away to make the link also work?

Thank you!

1

I appreciate this is not a cool answer, but, as per this question I made a few days ago; have you tried turning it off and on again?!

Standard object page "not supported on mobile device" in Salesforce1

The long and short is that you need to properly close SF1 on your mobile device (on most devices by accessing the application manager and swiping it out of sight).

The reason for this seems to be a local caching/setup problem in the app if you are trying to access new pages created synchronously with the Salesforce1 app being open and authenticated on your "test" device.

| improve this answer | |
  • Hi there, yes I have tried turning it off and on and I'm still getting the error. – Joanne May 8 '14 at 13:59
  • Bummer. Is this the standard view page for this object? Or do you have a Visualforce override for it perhaps? If so that needs to have the magic 'available for mobile' box checked? – Simon Lawrence May 8 '14 at 14:24
  • Standard, no Visualforce. – Joanne May 8 '14 at 15:06
0

You do not need to pass a link in, but the object Id. Notice the parameter is named entityId. Simply change your merged value to {!Tradeshow__c.Id}

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.