0

I cannot open a visualforce page on salesforce1 (but I can on salesforce) from a link sent in an email template. I want a user, who has received an email in their standard mail app on their mobile device, to be able to tap a link in this email and open the Salesforce1 mobile app on the VisualForce page with parameters(sent from the email template). I can enter to the opportunity in Salesforce1 from the link in email template. I used the full link of domain + '/' I still need to update this opportunity from email template too (I don't want to see it only), someone could help me?

Or any Solution to pass at least a parameter to SF1 through a standard page (the record of the object)? Any Ideas about this?

I tried this link : com.salesforce.salesforce1://entity/view?entityId={Your.Object.Id} in the email template : click link But in the email received the link (click link) is not clickable. Someone encountered this problem?

I need anything to connect from a link on the email template and generate any action on Salesforce1 (trigger(insert, update, delete), ...) even if it is a long turn.

Thank you in advance.

0

On the Visualforce page settings, you need to select Available for Salesforce mobile apps.

Available for mobile

1
  • thank you @Robin I tried it but it doesn't work in my case. When I click the link it redirect me to salesforce1 only without redirecting me to the visualforce page – BBS_ May 22 '15 at 13:32
0

I don't believe that its possible to load a VF page and pass parameters to it within the Salesforce1 app.

You can for example load up the view, edit, etc... pages via a url link. e.g. salesforce1://sObject/{sObject_id}/view

But you can't afaik load up a custom VF page (unless you have set it as a page override) and you can't pass parameters to it. It would be awesome for this functionality to exist...

Documentation can be found here

5
  • Thank you @Richard . I have seen many articles and comments with your same answer. But at least, I want to pass a parameter to the same object not only its id, without going through the Visualforce page. If someone could find a few things or any solution – BBS_ May 22 '15 at 13:40
  • Hello @Richard, I put this link salesforce1://sObject/<id>/view but I cannot click on this link in the email (it is not clickable), do you know why? Thank you – BBS_ May 25 '15 at 11:46
  • it is an Android phone not an ios is this the reason?? – BBS_ May 25 '15 at 11:55
  • Can't comment on Android but works ok on iOs, would have expected android to work though. Works ok on my iPhone with an email in the default mail client and fires up salesforce1. – Richard Durrant May 26 '15 at 10:54
  • Yes It is not working on Android devices – BBS_ May 28 '15 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.