5

In a bit of a bind here. I have just created a new, totally standard custom object in my Spring'14 DE, and added three fields to it with no problem (lookup to contact, number, text). I assigned it a custom tab and everything checked out.

I opened Salesforce1 and was pleased to see the new tab in the left nav, I can click through to it, see my records, click "New" - and successfully create a new record using the standard "New" page for this object (I haven't touched the page layout at all).

However,

When I do create one and click save (which navigates me to the detail page) or I try to OPEN one of these records in Salesforce1, I just get this page:

I thought a photo of the iPad was cooler than a screen grab

The page you are trying to access is not supported on mobile devices

I'm very curious, I've been back over all the options, and I don't think I've missed anything, I totally believed that standard layouts for custom objects were absolutely supported on mobile devices?

Edit: I have now edited the page layout, and the changes reflected straight away on the iPad in the create/edit page, but I have the same problem on View.

Edit 2: I have cleared the cached data a bunch of times, and other changes to other bits of the org have reflected perfectly through this process.

  • Do you have any Action overrides on your object? – Andrew Fawcett Apr 29 '14 at 10:44
  • Nope! This is a one day old DE, with this new custom object, completely unadulterated from creation, add three fields, create tab. – Simon Lawrence Apr 29 '14 at 10:47
  • Which version of Salesforce1 iPad app are you on? The latest version that came out in April end fixes a bunch of similar bugs which I've noticed earlier as well. – Gaurav Kheterpal May 5 '14 at 7:13
4

Ok. Well, I carried on working around in my org, and eventually got a "contact pages just loading up completely blank" problem.. so I force closed SF1 on the iPad, launched it again, and low and behold not only had the Contact detail page come back, the custom object detail page was now supported by mobile devices.

So my answer is, turn it off and on again...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.