0

I've created the one HTML content whose type is 'template' and now I'm trying to call that content using the AMPscrip function '%%=ContentBlockbyId("384201")=%%' in blank email template but it gives the error which in the below screenshot, enter image description here

3
  • 1
    It seems very odd to get a template and insert it into an email. That's not the way it should be, you should rather create a html content block or code snippet or whatever. But a template is a design for newsletters, therefore it makes no sense to insert a template into a newsletter neither it does vice versa. Mar 12, 2019 at 7:37
  • @JohannesSchapdick thank you for the response, yes I got it now. we can not directly call the templates and yes I've created the HTML content block and it worked. Mar 12, 2019 at 10:08
  • Also, the Content Block IDs are numbers, not strings. Mar 12, 2019 at 16:43

1 Answer 1

1

As per your question, you have created an HTML paste template whose ID is 384201. And you are trying to call this template in your email(and you are using blank template in this email, correct?).

You are getting this error because you need to create a content block(you can create HTML content block) instead of a template and then call that content block using ContentBlockbyID function in your email. You cannot call a template inside an email by using ContentBlockbyID function.

2
  • 1
    thank you for the response, yes tried by creating the HTML content block and it worked. Mar 12, 2019 at 10:04
  • @RushikeshPandit - please make sure to mark the answer as correct (checkmark next to the answer) if this has solved your issue to allow others to easily find the solution. Mar 12, 2019 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.