1

My requirement is to upload records with special characters.

i am following these steps :

  • Save the Excel sheet as "Unicode Text (.txt)".The new "*.txt" file is TAB delimited, not comma delimited, and therefore is not a true CSV.
  • Unless you can use a TAB delimited file for import in data loader, use your favorite text editor and replace the TAB characters with commas ",".
  • Launch data loader, click update
  • select object and browse the ".csv" file.

data loader stops at initializing the file and do not respond afterwards.

enter image description here

6
  • Why are you saving excel sheet as .txt. Use .csv directly. Dataloader exports data in csv formats. – Rohit Mourya Dec 15 '17 at 10:40
  • saving directly to .csv do not support special characters – Saumya Gaikwad Dec 15 '17 at 10:42
  • Ok. Did you tried Online Dataloader? – Rohit Mourya Dec 15 '17 at 10:46
  • try uploading this 그것을 이루지 못하는 것이 아니라 목표를 너무 낮게 잡아서 그것을 달성해 버리는 – Saumya Gaikwad Dec 15 '17 at 11:17
  • 1
    This may be an odd suggestion but you could download Libreoffice Calc. Its free and opensource and has good support for reading and writing csv files. You can than simply copy the information in your excel sheet and paste it into LibreOffice Calc. Save that as a csv file with quoted text field and encoding utf-8 and you should be-able to upload without any issues. (Mind you, this works only with small(ish) datasets. Don't use it for more than 50.000 records or so.) – Kasper Dec 15 '17 at 11:36
1

You need to convert your CSV encoding to UTF-8. Then try to insert data into Salesforce. This should work.

Please refer this link for converting CSV format to UTF-8. I'm highlighting those steps below:

  1. Make any modifications to your source data file in .xls format.

  2. In Microsoft® Excel®, save a copy of your file as a Unicode Text file.

  3. Open the Unicode Text file you just saved with a text editor.

  4. Click File | Save As to change the following file settings: File name extension—.csv

  5. Save as type—All Files Encoding—UTF-8

  6. Click Save, and close the file.

Below are some snapshots of my Developer org:

  1. Exporting Account having Name in Special Characters in CSV format:

enter image description here

  1. Below CSV file contents:

enter image description here

  1. Again imported that CSV file into my Dev org:

enter image description here

  1. Salesforce Org data snapshot:

enter image description here

2
  • still not working. – Saumya Gaikwad Dec 21 '17 at 9:51
  • @SaumyaGaikwad I've shared link in my answer. It should work. I followed those steps and it worked. I guess you're missing something. Also make sure you've checked Read all CSVs with UTF-8 encoding and Write all CSVs with UTF-8 encoding options in data loader to True. – Rohit Mourya Dec 21 '17 at 12:56
0

(not really an answer but) Works fine for me?

What do you have in DataLoader settings, especially the "Allow Tab as CSV delimiter"? I think it's ticked by default...

enter image description here

Maybe it hangs because the file is too big and it runs out of memory trying to cut (especially if it's looking for wrong delimiters)

1
  • already tried what you suggested – Saumya Gaikwad Dec 15 '17 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.