0

Dataloader requires CSV Files. When I convert my files to CSV it changes the numbers to "Scientific Notions":

Before:

490000501404

After:

enter image description here

Then they show up in Salesforce as Scientific Notions "4.90001E+11".

The only workaround that i've found is, Format the numbers in Excel to "Custom = 0", then dont open the file again, then insert the data with dataloader.

Is this really the only way to proper way to achieve this? Or is there a better way?

The main reason I ask is because I'm merging 500,000+ rows of data from one Org to another and all of that data will be broken down in roughly 20-30 spread sheets. :\

thanks

2

If you are using Dataloader, I believe, that's the best option (You are already doing it). DON'T open the file at all. You can try ETL tools, such as Informatica , Jitterbit etc

3
  • agreed. Do ALL of your work in xls and then save 2 files: datatoload_test.csv with all but the top 5 data row. datatoload_test.csv with the top 5 rows.NEVER open the csv files
    – SeanGorman
    Feb 25 '20 at 18:47
  • "all but the top 5 data row", What does that mean?
    – Steve
    Feb 25 '20 at 19:07
  • He simply means, one file has 5 rows in for a test. The second file with all your data has everything, but as you’ve already loaded in the first 5 rows as a test - remove these from the second file
    – n34_panda
    Feb 25 '20 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.