2

I am working using DataLoader 45.0.0 to migrate our current SF to FSC. When choosing the CSV file in the "Load Inserts" dialog in DataLoader, I am greeted with the full error "CSV Error: Invalid CSV file format. Please select a different file. Error getting header row from the CSV file."

This is the exact file that I have extracted from the originating database using DataLoader. I believe the error has something to do with the encoding/byte order marks on the file. Even when opening in Notepad++ and encoding in UTF-8 (no BOM) or performing the same task using a Python script, I still receive the same error.

Is there a way to find out what exactly DataLoader is looking for in the header row?

1
  • I have issues with comma and semi-comma. Did you try to replace one by other? IF not, I believe you should share a sample.
    – m Peixoto
    Commented Apr 5, 2019 at 14:48

3 Answers 3

1

I found this thread with similar problems.

Try the following:

  1. Make sure CSV encoding of data loader settings matches your file (make sure both are UTF-8). There are a variety of settings for CSV parsing: see image

enter image description here

  1. If that doesn't work, Try using dataloader.io instead of desktop client. It apparently gives more detail about errors / works better
1
  • Thanks very much Z33dawg. It was a combination of selecting other delimiters, and the top box "Read all CSVs with UTF-8 encoding". Cheers! Commented Apr 5, 2019 at 15:45
2

Check your Dataloader settings and see if you have anything in the "Other Delimiters" input box.

I was loading a csv that contained dashes "-" in field values. I kept getting the error, "CSV Error: Invalid CSV file format." because my settings included an Other Delimiter of "-":

After I removed the "Other Delimiter" my file loaded successfully.

1

We removed '-' from csv and it worked

1
  • 4
    Additional information would make this a better answer. Please edit your answer to include more information.
    – Derek F
    Commented Mar 9, 2022 at 14:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .