Skip to main content

Questions tagged [fielddefinition]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
34 views

SOQL on FieldDefinition object - "LIKE" and "NOT LIKE" Return Same Results?

Somehow, these two logically opposing queries return (almost) the same data. How in the world do EntityDefinition.QualifiedApiName LIKE '%ChangeEvent%' and NOT EntityDefinition.QualifiedApiName LIKE '%...
number41's user avatar
  • 980
2 votes
0 answers
568 views

Salesforce Flow - Is it possible to update a dynamic field?

I currently have a Record-Triggered Flow on Lead object which is not really complex, but with a lot of possible issue, and I'm pretty sure it can be improved. This Flow is basically updating some &...
Gachdel's user avatar
  • 21
0 votes
1 answer
484 views

Cannot download FieldDefinition data for Contact object

I cannot download the FieldDefinition data using the Tooling API for all Contact fields. I have used this query to get the Id for the Contact object: SELECT Id FROM EntityDefinition where ...
Rich's user avatar
  • 17
1 vote
1 answer
347 views

Custom metadata type Field Definition Data Type evaluating incorrectly in validation rule

A custom metadata type has a Field Definition related to an Entity. The following validation rule ensures the value of this field can only be a User lookup: AND( FieldDefinition__c != NULL, ...
Mossi's user avatar
  • 3,966
1 vote
1 answer
853 views

Why does my custom metadata field defintion query not work?

I'm reading the answer to this following question: How to get a field's API name when querying a field of datatype, Metadata Relationship(Field Definition) However, when I run the following ...
MetadataLater's user avatar
6 votes
2 answers
1k views

Get components of a compound field?

I am currently running into this limitation of Custom Metadata: Custom Metadata Relationships and Compound Fields Since it is still not possible to relate a record to a specific EntityParticle (e.g. ...
Adrian Larson's user avatar
  • 150k
1 vote
1 answer
741 views

Querying inlineHelpText using the tooling API

From my small experiments it seems that this field isn't queryable through the Tooling API. Using this query here: https://www.salesforce.com/services/data/v40.0/tooling/query?q=Select+Id,+...
akarnid's user avatar
  • 1,842