3

I installed Force.com IDE as Eclipse Luna plugin. Apex code completion is not working in Luna, but I can't switch back to Kepler now. In Force.com IDE installation manual Luna is not mentioned as a supported Eclipse version.

So I'd like to ask if it's a Luna-specific problem or there is a way to enable Apex code completion? And if yes, then how?

  • 4
    The Summer '14 Force.com IDE has taken a step back in auto-completion - see github.com/forcedotcom/idecore/issues/20. – Keith C Oct 17 '14 at 13:34
  • 1
    If you are willing to go back to Kepler just for your Force.com work, the versions of the Force.com IDE for API 29 and 30 (and the 31 that you have) are available as described in step 4 of developer.salesforce.com/page/Force.com_IDE_Installation. – Keith C Oct 17 '14 at 13:42
  • @KeithC, thanks. I found the answer in the first link you provided. There's Apex editor called Apex Editor LS, available as Eclipse plugin. It supports Apex code completion. Please add it as the answer, and thank you – justasd Oct 17 '14 at 14:22
  • Probably best if you post it as the answer after you've tried it; I don't know anything about it. – Keith C Oct 17 '14 at 15:05
  • Just in case you weren't aware, and for the benefit of others who might not be, you can have more than one instance of Eclipse on your machine at the same time. That would allow you to have an instance of Kepler to use should you need it while keeping your instance of Luna as well. Both would need to be maintained independent of one another. – crmprogdev Oct 17 '14 at 15:28
3

There's Apex editor called Apex Editor LS, available as Eclipse pugin. It supports Apex code completion. I tested it, works great.

| improve this answer | |
  • this one seems useful. I tried this. works fine. – Pasan Eeriyagama Jul 18 '17 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.