1

I am unable to deploy unlocked packages created with SFDX/CLI . I am receiving the "The package version is not fully available. If this is a recently created package version, try again in a few minutes or contact the package publisher." error message via the CLI, hours and days after the package version has been created. I have tried creating new package versions, but still receive the same error when trying to install the package to a sandbox org. When trying to install the package via the Salesforce UI, the UI won't accept the package installation key.

1
  • Not sure if it is related but I am currently experiencing issues with a managed package not becoming available. I built the patch version yesterday and it is still not available to push as of writing this. I expect it is some issue with the SF servers Jul 29, 2023 at 21:53

1 Answer 1

1

I am a Salesforce employee, but I am not a member of the packaging team. This answer reflects my experience but isn't an official comment by the company.

The warning to wait for a few minutes is usually the right call, and the few minutes can occasionally be a few hours. But in this circumstance, since you've waited days already, it's unlikely this problem will self-resolve.

This situation usually means that the package artifact has not propagated across instances as it is expected to. You may find you can install the package on the same instance where it was created.

There's no way for you to fix the issue, other than uploading a new package version once the underlying problem is resolved (and unfortunately, there's no way for you to tell when that's the case). If that's not an acceptable outcome, open a Support case.

The invalid key issue is probably related to the same underlying problem, although I haven't seen that one before.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .