8

I got the below message when trying to upgrade a service

Mismatching Versions

The AppExchange Application or component you have selected is not yet available on your instance of salesforce.com. Please check back in a few days to retry the installation. Press the back button of your browser now and bookmark the AppExchange Directory page so that you can find it later.

I uploaded a new version of my service a few hours ago and it seems that I can not use it (I tried to upgrade my customer's service). I guess there is a certain delay, did you encounter this error?

7

It sounds as if you have uploaded your package from a developer org that is already upgraded to the Winter'14 release. The problem is that we are right now in the middle of the Winter '14 release. Half of the Salesforce servers were upgraded this past weekend and the other half will be upgraded this coming weekend. This is the error your are encountering, that is, the instance you are trying to install your new package on version 29.0 of the API is still on version 28.0. Your only choice is to wait until the release takes place this weekend on the remaining servers before upgrading those instances with the new package. For more information about specific release dates and times, please visit http://trust.salesforce.com/

  • Thanks! how can I see what API version my customer is using? – Uri Lukach Oct 7 '13 at 15:12
  • 1
    You need to know what server they're on (NA2, NA14, etc.) and then you can reference the trust site. I don't know that there is a way to handle this in package install. – greenstork Oct 7 '13 at 16:33
  • I have uploaded my version in NA7 server which was upgraded to winter 2015 release, and I try to install onEU3 which still did not get this upgrade, how can I know when will the upgrade take place? I have been waiting more than one week .... – Uri Lukach Oct 13 '14 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.