Deployments were working fine before:

All of a sudden I am now getting an error message of "Invalid IOS url" when trying to deploy my ExperienceBundle site. It points to the metadata file as the issue e.g. the [file-name].site-meta.xml file in the ExperienceBundle folder.

My metadata file is small & looks just like this:

<?xml version="1.0" encoding="UTF-8"?>
<ExperienceBundle xmlns="http://soap.sforce.com/2006/04/metadata">
    <label>My Site Label</label>

Note: I've already tried retrieving from the target org that's failing and the metadata file does not change. I redeployed it anyway just to double test and still get the same Invalid IOS url error.

Also: I've also tried removing the "urlPathPrefix" property from the metadata file and deployed it again that way but still get the same Invalid IOS url error.

Thanks for any help.

1 Answer 1


It is a recent issue Salesforce is having due to their recent updates. Quoted from Salesforce:

"It is coming to our attention since after some new updates and patches. It is causing this problem. There are also few similar cases about it, which are also recent ones."

What resolved it for me were the following steps provided by Salesforce rep:

Go to:

Setup > All Sites > Builder > Settings > Mobile Publisher > App Settings

Under "App Store Link" type in https://apps.apple.com/us


Under "Google Play Link" type in https://play.google.com/store

Publish site and try deployment once more.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .