Questions tagged [experience-bundle]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
6 views

Deploying Experience site fails due to 'The value for urlPathPrefix in ExperienceBundle isn't valid. Check the value and try again.'

I am trying to deploy my Experience site to production with a change set, however I keep hitting The value for urlPathPrefix in ExperienceBundle isn't valid. Check the value and try again. Even though ...
1
vote
0answers
23 views

How to package a custom domain name for Experience (Community)

I have an experience that is packaged in an unlocked package. In production, we are using a custom domain, but we are not using that in the sandboxes. Whenever we deploy the package to production, ...
1
vote
1answer
78 views

Deployment Problems Experience (Network - no Network named "...." found)

I am currently trying the deployment of the Experience Cloud. Unfortunately, I am encountering the problem with the "Network" and that it cannot find them. I have attached a screenshot from ...
1
vote
1answer
149 views

Strange error when I want to deploy community to scratch org. Is it sfdx bug or I missing something?

When I trying to deploy community to my scratch org I receive following error. Template that I use is Build Your Own and has route service-not-available by default. Error force-app/main/default/...
0
votes
0answers
9 views

How to Modify the Standrad OOB links for Not a Member?

I am trying to modify the "Not a Member" to a new experience bundle page i created . but this is still navigating to "secur/CommunitiesSelfRegUi" page . I have overridden the URL ...
1
vote
3answers
83 views

Experiences deployment fails with "Component names can only contain alphanumeric characters, hyphens, colons, and underscores."

trying to migrate a community from one sandbox to another. Using SFDX and VSC. I do have ExperienceBundle enabled in both. When I run this command: sfdx force:source:deploy -p force-app\main\default\...
2
votes
0answers
45 views

SFDX Community create command is not working with template

I am trying to create a community with B2B Commerce template, but command is throwing error, I tried escape double quotes as well but getting the same error. Looks like I am unable to pass the proper ...
1
vote
1answer
35 views

Error on Experience Cloud filter during deploy (Account.Id on standard Chart component)

We are trying to push our Experience Site (using ExperienceBundle with mdapi) and are getting this error with the standard component. Seems like there was a similar issue that affected changesets: ...
1
vote
1answer
58 views

Service Not Available Page in Experience Bundle deployment issues [duplicate]

We are not using the new custom Service Not Available Page in Experience Bundle (as we do not have a CDN enabled). We're getting the following error while trying to install our package: "Your ...
3
votes
1answer
165 views

How do I package an upgradable Experience Builder Site?

I need to provide an unlocked package containing a customizable "starter kit" for using features of my managed package so customers have an easy starting point to create their own experience....
3
votes
1answer
196 views

Error creating scratch orgs with "Communities" enabled

I am following the steps listed here Build scratch org definition file in order to enable communities for a scratch org, but the following error is received: We couldn't find a template with the ID ...
1
vote
1answer
21 views

Community deplyment issues related to componentName

I am facing this error when I want to deploy my community site to another partial prod, the ERROR MESSAGE IS 'The value for componentName c:layout in partnerportalv31/views/home1.json isn't valid. ...
1
vote
0answers
64 views

Site.com deployment to other organisaton using change set

I am facing this error while trying to deploy a community portal to another organization We couldn't validate componentAttributes in partnerportalv31/views/recordList.json for component 0ff249c1-7e01-...
2
votes
2answers
505 views

Error when deploy experience bundle community using Ant migration tool

I am deploying the community experience bundle using Ant migration tool and I am receiving the following error. themes/buildYourOwn.json needs to be a Theme Layout Component. Update the file and try ...
4
votes
0answers
327 views

How do we deploy an Experience Bundle to a scratch org properly?

I'm finding it almost impossible to create a Scratch Org and push all code along with an Experience Bundle (Community). The Community has custom pages that reference Custom Objects in list component. ...
0
votes
1answer
328 views

Communities error when building new package version for code coverage

I'm attempting to build a new version of a package by using the --codecoverage switch like so: sfdx force:package:version:create -p myPackageName -w 100 -x --json --codecoverage --loglevel DEBUG ...
1
vote
1answer
323 views

sfdx force:package:version:create gave me erros

Now, I'm creating package version with community, custom object, custom tab, custom application but can't create version with the following errors. How can I solve it? test-unlocked-package git:(...
3
votes
0answers
640 views

ExperienceBundle: missing property renderPriority

I retrieved a ExperienceBundle and all the necessary dependencies from a sandbox and am trying to deploy to production. I keep having to manually add this renderPriority for a themed community. It ...
1
vote
0answers
37 views

How are CommunityTemplateDefinition image references made?

I am getting a gack when creating a new community based on my community template so am looking at the template's content to try to see what is wrong. There is an example of such a template in the ...
6
votes
1answer
359 views

Which metadata object stores NavigationMenu / TileMenu translations?

Does anyone know which metadata object stores translations for the NavigationMenu component? Specifically, I'm using a TileMenu component in the Community Builder. The help page says to use ...