0

We have refreshed our sandbox, and I'm trying to restore functionality of a package that has stopped working after the refresh.

I'm following the package installation instructions, which are clear, and this is how my org is currently configured:

  • Auth Provider - Callback URL = https://mydomain--test.sandbox.my.salesforce.com/services/authcallback/Salesforce_Enhanced_Picklists
  • Connected App - Callback URL updated to https://mydomain--test.sandbox.my.salesforce.com/services/authcallback/Salesforce_Enhanced_Picklists
  • Waited 10+ minutes
  • Named Credential - URL = https://mydomain--test.sandbox.my.salesforce.com

When I click Save on the Named Credential to start the auth flow, I get the following error:

"error=redirect_uri_mismatch&error_description=redirect_uri%20must%20match%20configuration"

Enhanced domains are enabled in our sandbox org, so I'm wondering if there's some other configuration value I need to change to support that, since it's currently not enabled in our production org where the sandbox was refreshed from.

I just can't figure out why it's having a problem with the URL I'm providing. Can anyone help?

1 Answer 1

0

I found the problem. The Auth Provider Consumer Key and Consumer Secret were outdated.

I got the updated key/secret by viewing the Connected App, and clicking the Manage Consumer Details button under Consumer Key and Secret. I then copied the new key and secret to the Auth Provider. After this was done, I was able to save the named credential without error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .