0

I created a new custom object and added it to a screen flow. That flow is using the Create Records step to try an create a new custom object.

The flow fails with the following error:

This error occurred when the flow tried to create records: INVALID_TYPE: sObject type 'Event_Registration__c' is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name. Please reference your WSDL or the describe call for the appropriate names.

I checked the Apex WSDL (setup -> api -> click 'Generate Apex WSDL' button) and noticed my custom object is not in the list. Maybe that's the issue?

How do I ensure my custom object shows up in the WSDL/Unblock creation of the custom object through my Flow

2
  • Is your custom object status 'In Development' or 'Deployed'?
    – Nick C
    Jun 9, 2021 at 0:40
  • It's marked as Deployed in Object Manager
    – JT Smith
    Jun 9, 2021 at 0:40

1 Answer 1

1

Most likely, you don't have Object Level Access (CRUD) on the object. Go to your Profile and add at those permissions to your profile, as well as any fields on the object you need to make the flow work.

2
  • Thanks, it does look like I don't have the permissions set correctly on the object. When I go to the community plus login profile (the profile of the user I'm mimicking) the custom object I created has no permissions (all boxes unchecked), but are greyed out so I can't edit them. Any idea on how to change the permissions?
    – JT Smith
    Jun 9, 2021 at 19:49
  • Commenting on my own question. I realized that standard profiles can't be edited, so I cloned the profile in question and updated my user and everything works now!
    – JT Smith
    Jun 9, 2021 at 21:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .