0

We are seeing this error whenever our .net developer is trying to insert a record into salesforce custom object.

sObject type 'xyz__c' is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name. Please reference your WSDL or the describe call for the appropriate names.

They have integrated using latest Enterprise WSDL. The user is set as "System Administrator". Besides all these we are seeing this error. We are not seeing this issue with Standard objects.

Any insights would be helpful.

Thank you.

  • Post some code and/or data model, at least full error description and then someone would be able to help – kurunve Feb 4 '16 at 15:22
  • That's the only error that I am receiving. – SFDC_BigDog Feb 4 '16 at 15:24
  • 1. Check the wsdl and ensure this object is in it. 2. Inspect the .net generated object and ensure it is correct. – Jesse Milburn Feb 4 '16 at 15:25
  • @JesseMilburn I have checked the WSDL and the object is present in it. Also the .net generated object is fine. This was working correctly with developer sandbox. We are trying this in full copy sandbox and we see the issue. Are we missing any thing. Also the WSDL that we have used is generated from full copy sandbox. – SFDC_BigDog Feb 4 '16 at 15:27
  • Is the object present and named the same on the full copy? – Jesse Milburn Feb 4 '16 at 15:30
1

You can debug it in below steps :

  1. Check if WSDL has this object (If its enterprise WSDL)
  2. Check if there is any change in API in destination Org.
  3. Check profile of running user if it has access to this Object.

I guess, user does not has profile level permission for this object.

If it still does not work, then please share if you are using Partner or Enterprise WSDL and you are getting error at compile time or during execution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.