0

EDIT: When I go to https://workbench.developerforce.com and I do not see the field which I have added, is that due to Managed release installed?

I have installed the Managed package in my org and then I have added few new fields to that custom object and I can see that fields are there but when I try to do SOQL query I get this error:

INVALID_FIELD: (Address__c)

SELECT id,name,Address__c FROM Employee__c

ERROR at Row:1:Column:30 No such column 'Address__c' on entity 'Employee__c'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

0

You need to include the namespace of the managed package in your query. Assuming that Employee__c is the object from the managed package and Address__cis a custom field that you added to it, your query should read like

SELECT id,name,Address__c FROM namespace__Employee__c

replacing namespace with the appropriate value

  • Yes I have tried with namespace and no avail also as I said in my question I don't even see the new field I have created in workbench.developerforce – Nick Kahn Sep 2 '15 at 18:29
0

I found the answer

when you add new fields to the managed package object you need to go to -->Manage-->Users>Permission Sets --> Object Settings --> select your object --> and check the READ/EDIT

Then

click on the newly field created and -->Click on Set Field Level Security and assign appropriately

Hope this will help others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.