I am trying to set up my Godaddy domain name so I can use it in salesforce to create community portals with. I am not sure how I am suppose to set up the Cname to ensure that the domain name can be picked up in salesforce set up.

In GoDaddy I have the name set up to our salesforce domain name which is admagic.force.com and the value is the domain name. When the domain name is put I get the "@" symbol taking it's place. Screenshot below

Godaddy Set up

When I try to set it up in salesforce I'm getting this error:

Error: Salesforce.com can't validate the domain. The CNAME record may still be processing (which can take up to 24 hours), or the domain may not belong to you. Make sure the domain name logisticscenter.online.00dj0000001nz89eae.live.siteforce.com uses logisticscenter.online.00dj0000001nz89eae.live.siteforce.com.00dj0000001nz89eae.live.siteforce.com as its CNAME target and try again later.

It's been days since this is has been set up on the Godaddy side here is a screenshot of the error in salesforce:

Domain Error

What steps do I have to do to resolve this?

Godaddy error

2 Answers 2


You must have a site domain that you have bought using go daddy. Let's say it is www.mydomaim.com

When you will try to add this to Salesforce it will error out and give you the CNAME. Now you need to add that CNAME in godaddy settings.

Once that is done it will be propagated to DNS servers all over the world.

After that goto Salesforce and add you custom domain again. This time it should get added. You may need to wait for upto 24 hours.

Then Click in activate. Open the domain in Salesforce and add your community in custom URL below.

Here is how CName will look like.

enter image description here

Example Steps:

In my case, I wanted my community to be available at https://utilities.manjitsingh.dev

  1. I tried adding utilities.manjitsingh.dev in Salesforce which gave me an error saying Make sure the domain name utilities.manjitsingh.dev uses utilities.manjitsingh.dev.00dj0000001nz89eae.live.siteforce.com.

  2. Click cancel then navigate over to my provider and added CNAME as shown in above picture.

  • Name = utilities. (In you case it will be www)
  • CNAME = utilities.manjitsingh.dev.00dj0000001nz89eae.live.siteforce.com
  • TTL = 1m (minute)

Clicked add.

  1. Waited for 1 hour.
  2. Went back to salesforce and added the domain again. It saves as the CNAME has propagated everywhere.
  3. Wait for Activate button to be enabled and then activated and attached the community in Custom URL's.
  • Hi thanks for replying, So I followed that and I still get an error. When setting up the Cname in godaddy what should the host name be? I'm putting my salesforce instance domain name as the host. Should I use a different host name?
    – Len Cadet
    Oct 26, 2020 at 16:59
  • @LenCadet I added some example steps.
    – manjit5190
    Oct 26, 2020 at 17:07
  • I'm sure if I posted my picture in the best way but I have a screen shot showing that I get an error when putting www when updating my Cname
    – Len Cadet
    Oct 26, 2020 at 17:28
  • I see that you already have a CNAME defined for www, third line in your first screenshot. You should try removing it and then adding a new one. If the error persists you may need to contact GoDaddy support.
    – manjit5190
    Oct 26, 2020 at 18:01
  • Yeah that part you put was correct. I updated the cname with the www has the name and the correct value and it worked!
    – Len Cadet
    Oct 27, 2020 at 2:25

Steps to create the custom domain are as follow as

  1. Create the CA-Signed Certificate from Salesforce
  2. Upload the Signed Certificate:
  3. Add a domain
  4. Custom URL if needed


  • Welcome to Salesforce Stack Exchange (SFSE)! Link-only answers are discouraged and may be deleted. (See: Why and how are some answers deleted?) Please edit your answer to add more information. (From How do I write a good answer?: "...please add context around the link so your fellow users will have some idea what it is and why it’s there. Always quote the most relevant part of an important link....")
    – Moonpie
    Jul 19, 2022 at 13:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .