2

We have a public salesforce site (http://blah.force.com/example), but would like to set up a custom domain for this site such as: example.domain.ca

Using this Salesforce help article as a guide: https://help.salesforce.com/articleView?id=000205653&type=1 our DNS manager created a sub-domain example.domain.ca and pointed it to example.domain.ca.00ri00000000g5o.live.siteforce.com. This step was completed over 72 hours ago)

Now I'm trying to add the custom domain information to Salesforce (Setup > Domains > Add a Domain)

In the Domain Name field I entered the sub-domain created (example.domain.ca) and then selected "A non-Salesforce host or service serves this domain over HTTPS" with the value example.domain.ca

Unfortunately that results in the following error. 'Error: Salesforce.com can't validate the domain. The CNAME record may still be processing (which can take up to 24 hours), or the domain may not belong to you. Make sure the domain name example.domain.ca uses example.domain.ca.00ri00000000g5o.live.siteforce.com as its CNAME target and try again later. It presently uses www.example.domain.ca.00ri00000000g5o.live.siteforce.com as the CNAME target, which does not equal the expected value.'

I'd appreciate any help or ideas on what the issue could be.

Screenshot below:

Error while saving domain

1

As the error says, there's a leading 'www' at the beginning of the CNAME that should not be there. You will need to modify the DNS entry so that it matches the expected value.

  • hai @sfdcfox & TW Merryweather am also facing same issue, my CNAME propagation have completed 10 days before.still i am getting this error, how can i solve this error. – Roman's YARD Dec 13 '18 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.