3

I have added the Calendar component to a page on my Salesforce Community. When I login as a Portal User and try to Add Calendar, I don't see the Public Calendar and Resources option in the dropdown. The calendar I've shared with this portal user has given Full Access to my portal user too.

On top of that, I made sure to give the profile access to events, activities, and tasks. Is there a permission for accessing Public Calendar and Resources I'm missing?

The option for Public Calendar and Resources should be visible in the dropdown I've clicked on.

Add Calendar Modal from the Calendar Component

2
  • I'm also having this issue - the user can see the events on the calendar (if given a link to the event, i.e. domain.force.com/communityname/s/detail/00UID00000fakeID00), but cannot select Public Calendars under the "Add Calendar" dialog. May 31 at 17:55
  • 1
    @DylanBowman what is the type of community user license: partner, customer community or customer community plus ?
    – Shamina
    May 31 at 20:09

2 Answers 2

3
+50

If you are accessing the experience site as internal user or partner user, Public Calendar and Resources will be visible. If you are using customer community or customer community plus user, then this option will not be visible. Refer to this help article

  • Internal users and partners users can add a public calendar to their Other Calendars section.
  • Customer users can’t access public calendars and events.

This seems to be a default behavior for customer community user. The access level defined for a user on the calendar only defines what the user can do on the calendar when its accessible and not the ability to add public calendars .

1
  • I was able to test this out in a Dev edition org.
    – arut
    Jun 1 at 7:21
-2

Kindly follow these steps below :

  1. Setup | Quick Find : Public Calendars and Resources

For reference : https://help.salesforce.com/articleView?id=sf.customize_groupcal.htm&type=5

I hope this helps :)

1
  • The question mentions that the calendar is shared with full access - this article only mentions how to give access. May 31 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.