0

I have a public community with a visualforce page as a payment gateway. With login it is displaying it correctly . But without login , its not displaying the input fields of the vf page. i have given the permission to create , read and edit the custom object used , still it is not displaying the input fields. Also while configuring the guest user profile , i'm not able to assign a default community to it.Please help me out! enter image description here

enter image description here

enter image description here

4
  • You can check that guest user profile from community builder/pages. It will have same name as community – Ysr Shk Oct 22 '20 at 9:19
  • @YsrShk yes , i went to the guest user profile through it and i have configure it through it . still it doesnt work – ashish singhal Oct 22 '20 at 9:25
  • Please check FLS/Record Type/Page/Class permissions. – Ysr Shk Oct 22 '20 at 9:26
  • @YsrShk i'm not sure if we can give Field level security for guest user . i have selected visible for all but there is no guest user radio button – ashish singhal Oct 22 '20 at 10:01
0

This is a Known Issues . In Review and not fixed yet. The updates section is wrong as it says the issue is fixed but you can check to the right of the page that it has not been fixed yet for multiple instances. We need to wait till this gets fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.