8

I have set a custom favicon on a Force.com site, but it is only working on the public site. The secure site still displays the default Salesforce favicon.

<mycompany>.force.com/favicon.ico is the custom favicon, but <mycompany>.secure.force.com/favicon.ico is the standard SF favicon.

From this question in the SF discussion forums, I understand that the custom favicon should take affect in a secure site if the site has no path. Yet, it is not working in our case.

For now, I'm adding <link rel="icon" href="{!$Resource.Favicon}" /> to the site template. However, I would prefer to do it declaratively if possible.

  • in the past i have seen this behavior, but for some reason it took a day or two to 'take effect'. I would add the favicon, and it wouldnt show like you said, but then a day or so later it was there. This was a few years ago, but i am wondering if it is still the case now. – SalesForceGirl Feb 6 '14 at 21:21
  • Hi Geeljire, I am sure you must have already did but trying luck ;) Did you tried any other browser which didnt opened that website or tried to clean all your cookies ? basically in my case I cleared cookies and all data and it started showing up. – Jitendra Zaa Dec 9 '14 at 0:08
1

We did this, and the favicon used by the site config page in salesforce works for both public and secure URLs...nothing extra to do there.

I didn't add the favicon on the site template.

I'd suggest giving it a few days. Is your site new, or just the favicon?

0

You can try this script.

<script type="text/javascript">
    $(document).ready(function(){

        var myvar  = '<title>Sample Title</title>';
        myvar +='<link rel="shortcut icon" href="{!URLFOR($Resource.favicon)}" type="image/png" />';

        $('head').append(myvar);

    })
</script>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.