4

I have a crated a 100% custom branded community and the only missing element is the favicon. I set the Favorite Icon in the force.com setting of the community and also tried <link rel="shortcut icon" href="{!URLFOR($Resource.Favicon)}" type="image/x-icon" /> but neither load the icon that I am wanting.

How can I replace the cloud?

  • I found that the <link rel="shortcut icon" ... only worked across all browsers when put in the <head>...</head> part of the page. – Keith C Oct 13 '14 at 17:58
  • I did create a <head></head> inside of the <apex:page>. Does the file type matter? I am using a .ICO which is what I use on our corporate site, not sure what is wrong honestly. Looking at the code on the rendered page the <link /> is not between the <head> tags. How can I force items between the <head>? – Grady D Oct 13 '14 at 18:02
  • .ico works fine for me. (I don't have the type parameter set.) In my pages I have the head section explicitly defined and all the standard Salesforce output turned off using showHeader="false" sidebar="false" standardStylesheets="false" applyHtmlTag="false". That gives me just the head section I want. – Keith C Oct 13 '14 at 18:09
1

Even I had the similar issue related to Favicon in my Community(Napili template) and I have fixed it. Credit goes to @glls. Here is the link to my question: Favicon is not working outside of the Community

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.