0

I have already set the apex debug level at FINEST but still when I check the variable panel I still see the message must trace APEX_CODE at Finest can someone please suggest on the same?

Below is the screenshot of my debug settings in developer edition.

enter image description here

enter image description here

Below is the variable panel in the developer console enter image description here

I Have tried the same on production, sandbox and developer edition but still I get the same message can anyone please suggest?

  • Can you screenshot your debug settings? – Brian Miller Apr 28 '19 at 8:02
  • Are you talking about using Checkpoints in the Developer Console, the old, paid apex debugger in Eclipse, or the Apex Replay Debugger in Visual Studio Code? – Derek F Apr 28 '19 at 12:08
  • Thank you so much for responding I have updated my question with the screenshots. – gs650x Apr 29 '19 at 5:12
  • That might just be for the SFDC_DevConsole settings but not the actual User settings for your session. Check those settings as well (which usually sit above what you're showing in the first screenshot) – Brian Miller Apr 29 '19 at 6:18
  • Hi @BrianMiller I have again updated my question with more detailed screenshots – gs650x Apr 29 '19 at 11:00
0

While having log panels up, make sure Debug only is unchecked. That way you can view the full execution log. To check variables, look at the event column, and wherever you see VARIABLE_ASSIGNMENT, click on each one and and the variables panel will update accordingly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.