Last year, I used dataloader to upload new leads with Asian characters by following this process: 1) In Excel, save file as unicode text 2) Open file in notepad, set Save As to UTF-8, select All Files type, and type in a .csv extension 3) Open dataloader and go...

I just tried with dataloader and am receiving an error message that says: CSV Error: Invalid CSV file format. Please select a different file. com.sforce.async.CSVReader$CSVParseException: Found unescaped quote. A value with quote should be within a quote.

Thing is, I tried with a file that I successfully uploaded in December. What has changed? Thanks for any feedback.

  • Did you change your laptop ?What machine you are in? Commented Jan 21, 2014 at 18:47
  • I did change laptops but the old was a Dell and the new is a Dell (Lattitude E6330). But, I used data loader on an old file that I had used successfully in December (with no changes to file) and still got the error.
    – user5408
    Commented Jan 21, 2014 at 20:04
  • You might also consider using some of the other data loading options if you're stuck. Jitterbit and Dataloader.io are two options Commented Jan 21, 2014 at 20:54
  • Thanks for everyone's input. Turns out that data loader 29.0 had the issue. A colleague with an older version was able to upload with no issues.
    – user5408
    Commented Jan 23, 2014 at 14:08

3 Answers 3


You're doing several file manipulations with various utilities and while it seems like that should work to convert an excel spreadsheet to CSV there are probably a lot of pitfalls to avoid.

You might check out this question on Stackoverflow about exporting Excel spreadsheets as unicode csv files.

Personally I think this answer has the best approach (but there are several options):

  1. Save as a CSV from excel
  2. Run CSV unicode converter

You can use iconv command under Unix (also available on Windows as libiconv).

After saving as CSV under Excel in the command line put:

iconv -f cp1250 -t utf-8 file-encoded-cp1250.csv > file-encoded-utf8.csv

(remember to replace cp1250 with your encoding).

Works fast and great for big files like post codes database, which cannot be imported to GoogleDocs (400.000 cells limit).

  • Thanks. I just tried Google and it mangled the Asian characters. I used an older file as a test (without changing anything) and though it worked in December, it no longer works now. Seems like something changed with data loader. The other solution looks a bit involved but I'll take a look. Thanks for input.
    – user5408
    Commented Jan 21, 2014 at 20:09
  • Based on the error message you're getting it doesn't sound like a data loader issue, it sounds like your method for converting things to UTF-8 is corrupting the data. If I had to make a long shot guess, I'd say that the source file has quotes in some of the values (which have to be properly escaped), and that the last file you tried it with didn't have them. Commented Jan 21, 2014 at 20:54
  • Thanks Ralph and everyone else. You may be right. But, when I tried today with a file I successfully uploaded in December, I got the error. So, something has changed in the last month or so... Stumped, but I'll keep plugging away. Thanks again.
    – user5408
    Commented Jan 22, 2014 at 4:07

Two questions.

  1. What's the encoding in the Data Loader's settings?

    enter image description here

    (not the best sample image but you get the hint)

  2. Any special reason why you use DL at all, why not the standard Lead import wizard and let the SF deal with their own... ;)

  • I have the read CSVs with UTF-8 encoding checked. That is what has worked in the past with the files in the format I've used. Regarding #2, I have 20,000 records. I'm not an Admin, but occasionally help out with some things. It was my understanding that dataloader was more efficient for large data sets.
    – user5408
    Commented Jan 21, 2014 at 20:07
  • Out of ideas at the moment. If you believe it's a change in DL - try an older version? success.salesforce.com/answers?id=90630000000gppPAAQ
    – eyescream
    Commented Jan 21, 2014 at 20:13
  • 1
    Old version of data loader worked. Thanks for everyone's input.
    – user5408
    Commented Jan 23, 2014 at 14:08
  • Most peculiar! Can you answer your own question then & accept it? I'll happily upvote it and it'll go "off the radar". And thanks for coming back hereand sharing, more people will benefit from your effort :)
    – eyescream
    Commented Jan 23, 2014 at 14:19

Check if your new laptop supports Asian Languages, go to:

Control Panel - Regional and Language Settings and on the Languages Tab ensure "Install files for Asian Languages" is checked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .