I created a lightning component and a quick action that points to that component. Now I dragged that button in the Salesforce Mobile and Lightning Experience Actions section and it does not show up at the top inline with the other button. It shows up as a tab instead.

Anyone knows why? or is there something i did wrong or missed? Thanks!

enter image description here

  • You will also find a button with same name. Try to drag that in "Lightning action". – Tushar Sharma Jul 11 at 7:21
  • which interfaces does your lightning component implements? – Itai Shmida Jul 12 at 8:14
  • @ItaiShmida, - flexipage:availableForAllPageTypes,flexipage:availableForRecordHome,force:lightningQuickAction,force:hasRecordId – krisstannum Jul 12 at 22:55
  • @TusharSharma, yes it is already dragged from the Mobile & Lightning Actions to the Salesforce Mobile and Lightning Experience Actions section. – krisstannum Jul 12 at 22:58

This is a expected behaviour from salesforce when feed tracking is enabled for cases or work orders, the page-level action menu on those records contains only custom buttons and supported standard buttons. Quick actions appear on the Chatter tab.

workaround:-

So in order to not see the action in the feed on Case or Work orders object record, you need to disable the feed tracking for your case object.

Steps are:- setup--> feed tracking--> select case--> disable it and save

Reference:- https://help.salesforce.com/articleView?id=actions_in_lex.htm&type=0

Hope it helps you.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.