1

I have the following configuration set and still Email and Task buttons not showing in the chatter lightning Lead Object:

1- Deliverability = All Emails

2- Task Has a record type

3- Feed Tracking is turned On for Lead Object

4- I have add Email and Task button on the Lead page layout in both sections 'Salesforce Mobile and Lightning Experience Actions' and 'Quick Actions in the Salesforce Classic Publisher' , and made sure that im viewing the right page layouts

5- I add Email and Task button to the Global Publisher Layout in both sections 'Salesforce Mobile and Lightning Experience Actions' and 'Quick Actions in the Salesforce Classic Publisher'

6- I do have Chatter Settings -> Enable Actions in the Publisher -> set to true

here screen shots

Screenshot Number 1

enter image description here

Screenshot Number 2

enter image description here

Screenshot Number 3

enter image description here

Screenshot Number 4

enter image description here

Screenshot Number 5

enter image description here

Screenshot Number 6

enter image description here

but nothing is working

enter image description here

  • Try this: 1) Setup -> Email -> Enhanced Email - enable this. 2) Enable Email-to-Case. I've had issues in the past where the email quick action wasn't showing up and these helped. Not sure what the issue is for Tasks not showing up – Brian Miller Apr 20 at 20:57
1

The issue was I needed to add the 'Activities' lightning standard component to the page instead of the 'Chatter' component.

Please follow below steps: 1. Go to Lead record details Page >> click on Setup Icon >> select Edit Page. (it redirects to the lightning app builder page setup) 2. Search for 'Activities' component and drag to the Page where ever you want to display. 3. Save the page and Go to any lead record detail page.

Now you can see the Email / New Task buttons as below.

0

Did you also dragged and drop in this section? (lead layout) enter image description here

  • Yes i did that, and if you look I have as screenshot number 4, not working – AB74574 Apr 19 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.